Bug 460888 - Upgrade to latest ekiga beta - 2.9.90
Upgrade to latest ekiga beta - 2.9.90
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ekiga (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On: 461363
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-02 08:16 EDT by Peter Robinson
Modified: 2008-09-29 10:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 10:01:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My attempt at a spec file (10.57 KB, text/plain)
2008-09-05 16:57 EDT, Daniel Veillard
no flags Details
opal.spec diff for upgrade to ekiga 3 beta 1 (2.74 KB, patch)
2008-09-11 10:27 EDT, Peter Robinson
no flags Details | Diff
ekiga.spec diff for upgrade to ekiga 3 beta 1 (3.50 KB, patch)
2008-09-11 10:28 EDT, Peter Robinson
no flags Details | Diff
updated opal.spec diff for upgrade to ekiga 3 beta 1 (2.72 KB, patch)
2008-09-11 15:50 EDT, Peter Robinson
no flags Details | Diff

  None (edit)
Description Peter Robinson 2008-09-02 08:16:08 EDT
Upgrade to the latest ekiga beta. ptlib has replaced pwlib. Version 3 is due out in the same timeframe as gnome 2.24. I have it all building on rawhide so if you want someone to review it or me to package it all up to assist the process let me know.

http://mail.gnome.org/archives/ekiga-devel-list/2008-September/msg00005.html
Comment 1 Daniel Veillard 2008-09-03 05:08:13 EDT
Yes but the problem is that they renamed pwlib as ptlib, as a result
this is way more work, a new package and I'm not sure this can be done 
in time for Fedora 10,

Daniel
Comment 2 Peter Robinson 2008-09-03 06:25:42 EDT
yes, I know they have. its essentially the same so its an easy conversion. I can either package it or review it if you like. I can do most of the the work if you would like, let me know what needs to be done.
Comment 3 Daniel Veillard 2008-09-03 08:22:57 EDT
Well if you want to co-maintain, I'm all for it !
Maybe i can make the first ptlib version and you review it
that's probably the fastest and maybe we can hit the deadline for F-10

Daniel
Comment 4 Peter Robinson 2008-09-03 08:53:05 EDT
Works for me. By the sound of it on fedora-devel F-10 may well be the base for RHEL-6 and I think ekiga 3 would be a must for that as well... and I don't want to be pushing manual updates to my boxes :-)

Peter
Comment 5 Peter Robinson 2008-09-05 07:43:01 EDT
I've put up some srpms of the beta for ptlib/opal/ekiga on http://pbrobinson.fedorapeople.org/ if you want to use them as a base for the updates.
Comment 6 Daniel Veillard 2008-09-05 16:53:03 EDT
Okay, I have just too much trouble trying to package them myself,
I don't have a F-10 beta available, libv4l-devel is nowhere to be found
for me for testing. I suggest you go ahead and request the new package
you will go way faster than me at it :-\ , sorry for slowing things down !

I also put mclasen in Cc as he can review the package too.
Comment 7 Daniel Veillard 2008-09-05 16:57:17 EDT
Created attachment 315937 [details]
My attempt at a spec file

I just kept a few things like the changelog, most cleanups from 
Peter Robinson looks fine to me. I just don't know about the status
of things like libdv, libraw1394, libavc1394 in F-10.
Comment 8 Daniel Veillard 2008-09-05 17:05:33 EDT
To probinson:

Also request approvals to commit on opal and ekiga
https://admin.fedoraproject.org/pkgdb/packages/name/opal
https://admin.fedoraproject.org/pkgdb/packages/name/ekiga

so that you can push the updates at the same time as ptlib,

Daniel
Comment 9 Peter Robinson 2008-09-06 12:31:46 EDT
OK, filed bug #461363 that this now depends on. I've currently removed the avc support as it can be easily added back later (and if the avc cameras are supported via v4l it should be usable through libv4l anyway). Also removed the obsolete of pwlib as they are installable side by side and it will make for an easier upgrade and can be obseleted later.

Also requested approval to commit on devel for ekiga and opal.
Comment 10 Peter Robinson 2008-09-09 12:41:44 EDT
Anyone able to do the ptlib package review?
Comment 11 Matthias Clasen 2008-09-09 14:34:57 EDT
Sorry, yeah. I'll get to it later today.
Comment 12 Peter Robinson 2008-09-11 10:24:59 EDT
OK, ptlib is built for rawhide (unfortunately missed todays build). I'll merge my spec file changes into the current cvs spec files for opal and ekiga in a couple of days but first I'll attach the patches for the spec files here for any feedback. I've fed both the opal and ekiga changes through rpmlint. There's no massive changes from the prev versions.

$ rpmlint /usr/src/redhat/RPMS/x86_64/opal*3.3.1-1.fc9.x86_64.rpm
opal.x86_64: W: obsolete-not-provided openh323
opal-devel.x86_64: W: no-documentation
opal-devel.x86_64: W: obsolete-not-provided openh323-devel
3 packages and 0 specfiles checked; 0 errors, 3 warnings.

$ rpmlint /usr/src/redhat/RPMS/x86_64/ekiga-2.9.90-1.fc9.x86_64.rpm
ekiga.x86_64: W: non-conffile-in-etc /etc/gconf/schemas/ekiga.schemas
ekiga.x86_64: W: obsolete-not-provided gnomemeeting
1 packages and 0 specfiles checked; 0 errors, 2 warnings.
Comment 13 Peter Robinson 2008-09-11 10:27:20 EDT
Created attachment 316446 [details]
opal.spec diff for upgrade to ekiga 3 beta 1
Comment 14 Peter Robinson 2008-09-11 10:28:22 EDT
Created attachment 316447 [details]
ekiga.spec diff for upgrade to ekiga 3 beta 1
Comment 15 Peter Robinson 2008-09-11 15:50:45 EDT
Created attachment 316479 [details]
updated opal.spec diff for upgrade to ekiga 3 beta 1

Updated patch to fix some koji build issues.
Comment 16 Peter Robinson 2008-09-11 16:55:09 EDT
Comment on attachment 316446 [details]
opal.spec diff for upgrade to ekiga 3 beta 1

obsolete
Comment 17 Peter Robinson 2008-09-14 14:52:29 EDT
Pushed opal and ekiga updates to devel.
Comment 18 Peter Robinson 2008-09-15 13:15:00 EDT
OK. This ekiga 3 beta has been cleared to land in Fedora 10 beta
https://fedorahosted.org/rel-eng/ticket/805
Comment 19 Peter Robinson 2008-09-29 10:01:29 EDT
The ekiga beta will be in the F10 beta, and the final v3 release has hit rawhide now.

Note You need to log in before you can comment on or make changes to this bug.