Bug 460913 - Error Type: <type 'exceptions.UnicodeDecodeError'>
Summary: Error Type: <type 'exceptions.UnicodeDecodeError'>
Keywords:
Status: CLOSED DUPLICATE of bug 468602
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-09-02 16:19 UTC by Alexey Kuznetsov
Modified: 2008-10-26 18:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-26 18:09:40 UTC
Type: ---


Attachments (Terms of Use)

Description Alexey Kuznetsov 2008-09-02 16:19:13 UTC
Description of problem:
After i switch my localization from English to Russian i start to get that error message for any package installed/upgraded:



Error Type: <type 'exceptions.UnicodeDecodeError'>
Error Value: 'ascii' codec can't decode byte 0xd0 in position 66: ordinal not in range(128)
  File : /usr/share/PackageKit/helpers/yum/install-files.py , line 20, in <module>
    backend.install_files(trusted, files_to_inst)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1034, in install_files
    self._runYumTransaction()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1139, in _runYumTransaction
    rpmDisplay=rpmDisplay)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 2848, in processTransaction
    self._doTransaction(callback,display=rpmDisplay)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 2952, in _doTransaction
    self.runTransaction( cb=cb )
  File : /usr/lib/python2.5/site-packages/yum/__init__.py , line 772, in runTransaction
    errors = self.ts.run(cb.callback, '')
  File : /usr/lib/python2.5/site-packages/yum/rpmtrans.py , line 317, in callback
    self._instProgress( bytes, total, h )
  File : /usr/lib/python2.5/site-packages/yum/rpmtrans.py , line 398, in _instProgress
    self.complete_actions, self.total_actions)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1712, in event
    self._showName(self.info_actions[action])
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 1705, in _showName
    self.base.package(id,status,"")
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py , line 269, in package
    PackageKitBaseBackend.package(self,id,status,summary)
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py , line 102, in package
    print >> sys.stdout,"package\t$s\t$s\t$s" $ (status,id,summary)

Comment 1 Richard Hughes 2008-10-26 18:09:40 UTC

*** This bug has been marked as a duplicate of bug 468602 ***


Note You need to log in before you can comment on or make changes to this bug.