Bug 460914 - Module reference count leak in multipath
Module reference count leak in multipath
Status: CLOSED DUPLICATE of bug 459092
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper (Show other bugs)
5.3
All Linux
medium Severity low
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-02 12:31 EDT by Mikulas Patocka
Modified: 2010-01-11 21:18 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-02 12:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Path for the problem (539 bytes, patch)
2008-09-02 12:31 EDT, Mikulas Patocka
no flags Details | Diff

  None (edit)
Description Mikulas Patocka 2008-09-02 12:31:43 EDT
Created attachment 315570 [details]
Path for the problem

When the user loads multipath with invalid arguments, there is memory leak and module reference count leak.

Try this:
dmsetup create --table '0 2 multipath 0 0 1 1 round-robin /dev/sdh' mpath0

After the command, the reference count on dm_round_robin is 1, although the module is unused, and it prevents further removal of the whole dm subsystem.
Comment 1 RHEL Product and Program Management 2008-09-02 12:42:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Mikulas Patocka 2008-09-02 12:56:23 EDT

*** This bug has been marked as a duplicate of bug 459092 ***

Note You need to log in before you can comment on or make changes to this bug.