Bug 460917 - fixes for namespaces, content type, syncml 1.2
fixes for namespaces, content type, syncml 1.2
Status: CLOSED DUPLICATE of bug 459696
Product: Fedora
Classification: Fedora
Component: wbxml2 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Laurent Rineau
Fedora Extras Quality Assurance
http://bugs.debian.org/cgi-bin/bugrep...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-02 12:59 EDT by Juha Tuomala
Modified: 2008-10-14 06:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-08 14:31:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch from debian mail (5.99 KB, patch)
2008-09-02 12:59 EDT, Juha Tuomala
no flags Details | Diff
Improved spec with patch and release bump. (4.73 KB, text/plain)
2008-09-02 13:01 EDT, Juha Tuomala
no flags Details
Additional fix for MaxSize in OMA DS 1.2 DevInf (682 bytes, patch)
2008-09-03 12:55 EDT, Juha Tuomala
no flags Details | Diff
New spec for all patches. (4.87 KB, text/x-rpm-spec)
2008-09-03 12:56 EDT, Juha Tuomala
no flags Details

  None (edit)
Description Juha Tuomala 2008-09-02 12:59:11 EDT
Created attachment 315571 [details]
Patch from debian mail

Description of problem:
Fedora shipped wbxml2 has few major flaws and needs to be patched.
Upstream has not yet released new version containing these fixes 
and is probably not likely do so as latest release is from year
2006 and they doesn't seem to be very responsive.

http://libwbxml.aymerick.com/ is the project homepage.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=487217
> wbxml_encoder.c:
>    incomplete SyncML 1.2 detection
> wbxml_tables.c:
>    wrong namespaces (the specifications of SyncML require big letters)
>    (e.g. SYNCML:SYNCML1.1 and not syncml:SYNCML1.1)
> wbxml_tree.c:
>    missing debug statement in case of an error
>    missing content type (function is used by XML and WBXML callbacks)
> wbxml_tree_clb_xml.c:
>    localName includes the namespace of a tag (syncml:devinf:DevInf)

Version-Release number of selected component (if applicable):
0.9.2-13.fc9

How reproducible:
Always.

Steps to Reproduce:
1. compile latest opensync + libsyncml svn and try to sync mobile.
  
Actual results:
http://libsyncml.opensync.org/ticket/144

Additional info:
Debian and suse are already shipping this patch. Lack of this prevents using
libsyncml and opensync svn versions.
Comment 1 Juha Tuomala 2008-09-02 13:01:27 EDT
Created attachment 315572 [details]
Improved spec with patch and release bump.

Spec adding previous patch with increased release.
Comment 2 Juha Tuomala 2008-09-03 12:55:57 EDT
Created attachment 315665 [details]
Additional fix for MaxSize in OMA DS 1.2 DevInf
Comment 3 Juha Tuomala 2008-09-03 12:56:40 EDT
Created attachment 315666 [details]
New spec for all patches.
Comment 4 Juha Tuomala 2008-09-08 14:31:23 EDT

*** This bug has been marked as a duplicate of bug 459696 ***
Comment 5 Laurent Rineau 2008-09-08 15:50:00 EDT
Juha, Yan, sorry for the delay. I have lost interrest for wbxml2 (mostly because opensync does not seem ready to sync KDE and my Nokia E65). As Debian already accepted that patch, I will build a new release of wxbml2, unless Andreas, the other Fedora maintainer for wbxml2, tell me that he is handling that bug before tomorrow.

(Well, if i forget, please remind me! ;-)
Comment 6 Juha Tuomala 2008-09-09 03:31:32 EDT
Comment #5:
> Juha, Yan, sorry for the delay. I have lost interrest for wbxml2 (mostly
> because opensync does not seem ready to sync KDE and my Nokia E65).

That's true, it's not ready yet. But there is serious effort for it
and not keeping the vital os libs working, is going to drive
testers away, slowing the project down. Compiling the opensync to 
working level is still quite tedious.

Once I get further on my fedora career, I can take this pkg over since
I've been active in opensync anyway.

Thanks for responding.
Comment 7 Juha Tuomala 2008-09-19 03:43:22 EDT
comment #5
> (Well, if i forget, please remind me! ;-)

ping! so did you?
Comment 8 Juha Tuomala 2008-10-14 06:13:27 EDT
I suggest you orphan this and related pkgs if you don't have time nor interest to maintain them.

Note You need to log in before you can comment on or make changes to this bug.