Bug 460952 - --skip-broken infinite loop
--skip-broken infinite loop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-02 15:39 EDT by Bill Nottingham
Modified: 2014-03-16 23:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-01 05:19:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum log (gzipped) (28.19 KB, application/octet-stream)
2008-09-02 15:39 EDT, Bill Nottingham
no flags Details
output from "yum update" gzipped (2.33 KB, application/unix-tar)
2008-09-13 00:00 EDT, Eric Harney
no flags Details
output from "yum update -d10 perl --skip-broken" gzipped (46.28 KB, application/unix-tar)
2008-09-13 00:01 EDT, Eric Harney
no flags Details

  None (edit)
Description Bill Nottingham 2008-09-02 15:39:25 EDT
Created attachment 315582 [details]
yum log (gzipped)

Description of problem:

Pointed at the koji static repos.

Version-Release number of selected component (if applicable):

yum-3.2.19-2.fc10.noarch

How reproducible:

Every time

Steps to Reproduce:
1. yum --skip-broken upgrade
Comment 1 Tim Lauridsen 2008-09-08 09:27:33 EDT
Bill, could you please attach the log from there commands:

yum update libvolume_id --skip-broken -d9

yum update libcurl --skip-broken -d9

there is a couple of issues here:

1. libcurl can't be updated because of the flash-plugin needs 'libcurl.so.3' and
the updated libcurl provides 'libcurl.so.4'

2. libvolume_id cant be updated (required by hal) because of gfs2-utils-2.99.08-1.fc10.x86_64 needs 'libvolume_id.so.0()(64bit)' and the updated libvolume_id provides 'libvolume_id.so.1()(64bit)' that is required by hal.

3. skip-broken don't goes crazy trying to eliminate the the updates causing the problems, it might not be able to solve it, but it should clean out all the updates and end up with and empty transaction.

I'm not sure that and upgrade can be made without removing flash-plugin or make compat package containing libcurl.so.3.
gfs2-utils needs to be remove or fixed to depend on libvolume_id.so.1()(64bit).
Comment 2 Bill Nottingham 2008-09-08 13:33:39 EDT
I can't, because the package set is happy today. :/
Comment 3 Eric Harney 2008-09-12 23:58:37 EDT
I just hit this on an F9 system, will attach logs for "yum update --skip-broken" and "yum update --skip-broken perl"
Comment 4 Eric Harney 2008-09-13 00:00:28 EDT
Created attachment 316645 [details]
output from "yum update" gzipped
Comment 5 Eric Harney 2008-09-13 00:01:24 EDT
Created attachment 316646 [details]
output from "yum update -d10 perl --skip-broken" gzipped
Comment 6 Tim Lauridsen 2008-11-01 05:19:17 EDT
These skip-broken issues whould be fixed in the current yum version in rawhide.
I will close this report, because that repo inconsistency normally dont stay around for long, so it is hard to retest.

Note You need to log in before you can comment on or make changes to this bug.