Bug 460979 - Can HTS log the audio codec info?
Can HTS log the audio codec info?
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 00:54 EDT by QinXie
Modified: 2014-03-25 20:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ======= Checking audio codec information is a tedious work for reviewers. Consequence: ============ No audio codec information recorded in the test results. Fix: ==== Record the audio codec information in the test results. Result: ======= It's easier for reviewers to verify the audio codec information from the test results.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 12:34:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
audio patch changing device planned for to use 'alsa.pcm_class' = 'generic' (471 bytes, patch)
2009-06-12 17:44 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description QinXie 2008-09-03 00:54:31 EDT
Sometime, vendor just provide the audio codec info but not the controller name or model name in the spec. In this case, the only way to verify hardware is to ask vendor, because no audio codec info is logged by HTS now.
How about add codec info into the test output? So that, we can short the review time and avoid the risk of vendor giving us the wrong message. 

Maybe these two files can be used:
tail -2 /proc/asound/oss/sndstat
head -2 /proc/asound/card0/codec97#0/ac97#0-0
Comment 4 Greg Nichols 2009-06-12 17:44:01 EDT
Created attachment 347673 [details]
audio patch changing device planned for to use 'alsa.pcm_class' = 'generic'
Comment 7 Yan Tian 2009-08-13 05:35:57 EDT
Verified v7-1.0-14.el5 audio test log file included following info on RHEL5.4 Server x86_64 system:

Sound Card:
udi = /org/freedesktop/Hal/devices/pci_10de_26c
  info.bus = pci
  info.linux.driver = HDA Intel
  info.parent = /org/freedesktop/Hal/devices/computer
  info.product = MCP51 High Definition Audio
  info.udi = /org/freedesktop/Hal/devices/pci_10de_26c
  info.vendor = nVidia Corporation
  linux.hotplug_type = 1
  linux.subsystem = pci
  linux.sysfs_path = /sys/devices/pci0000:00/0000:00:10.1
  linux.sysfs_path_device = /sys/devices/pci0000:00/0000:00:10.1
  pci.device_class = 4
  pci.device_protocol = 0
  pci.device_subclass = 3
  pci.linux.sysfs_path = /sys/devices/pci0000:00/0000:00:10.1
  pci.product = MCP51 High Definition Audio
  pci.product_id = 620
  pci.subsys_product = Unknown (0x1f90)
  pci.subsys_product_id = 8080
  pci.subsys_vendor = Dell
  pci.subsys_vendor_id = 4136
  pci.vendor = nVidia Corporation
  pci.vendor_id = 4318
Comment 9 YangKun 2009-08-20 23:32:38 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
Cause:
=======
Checking audio codec information is a tedious work for reviewers.

Consequence:
============
No audio codec information recorded in the test results.

Fix:
====
Record the audio codec information in the test results.

Result:
=======
It's easier for reviewers to verify the audio codec information from the test results.
Comment 10 errata-xmlrpc 2009-08-27 12:34:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1234.html

Note You need to log in before you can comment on or make changes to this bug.