Bug 460987 - System.ApplicationException: Could not find org.freedesktop.Hal
System.ApplicationException: Could not find org.freedesktop.Hal
Product: Fedora
Classification: Fedora
Component: podsleuth (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-09-03 02:26 EDT by David Nielsen
Modified: 2008-09-24 20:13 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-09-04 00:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2008-09-03 02:26:40 EDT
Description of problem:
Podsleuth is currently entirely non-functional on F9, even after the recent rebuild in koji of 0.6.2. I get the following in the debug file:

Pre-Mount Settings:
  - UDI:                    /org/freedesktop/Hal/devices/volume_uuid_5481_3F08
  - Block Device:           /dev/sdb2
  - Temporary Mount Point:
  - FS Type:


System.ApplicationException: Could not find org.freedesktop.Hal
  at Hal.Device.CastDevice[IDevice] () [0x0003a] in /builddir/build/BUILD/podsleuth-0.6.2/src/PodSleuth.Hal/Hal/Device.cs:284
  at Hal.Device..ctor (System.String udi) [0x0000d] in /builddir/build/BUILD/podsleuth-0.6.2/src/PodSleuth.Hal/Hal/Device.cs:127
  at PodSleuth.HalFrontend.HalPopulator.RunInternal (System.String[] args) [0x0001f] in /builddir/build/BUILD/podsleuth-0.6.2/src/PodSleuth.Hal/PodSleuth.HalFrontend/HalPopulator.cs:54
  at PodSleuth.HalFrontend.HalPopulator.Run (System.String[] args) [0x00000] in /builddir/build/BUILD/podsleuth-0.6.2/src/PodSleuth.Hal/PodSleuth.HalFrontend/HalPopulator.cs:24

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Update podsleuth
2. reboot (to restart hal - please remember to mark updates with the reboot flag in bodhi)
3. run podsleuth
Actual results:
the above error in the debug file

Expected results:
glorious iPod support

Additional info:
I had to seperately install sg3_utils-libs since podsleuth requires it to run but does not pull it in.
Comment 1 Michel Alexandre Salim 2008-09-03 14:05:10 EDT
Ah, thanks. I was doing some local builds while working on podsleuth, and so my development machine already has the required libraries installed. Didn't realize that automatic Mono dependency tracking does not work that well.
Comment 2 David Nielsen 2008-09-03 15:34:53 EDT
just to be clear, pulling that in won't fix this issue, it just exposes it since podsleuth otherwise runs to mamma complaining that it is missing
Comment 3 Michel Alexandre Salim 2008-09-03 22:33:13 EDT
Bizarre. Have you tried the following?

1. Unplug iPod
2. Restart haldaemon
2. Plug in iPod

As I recall, only then did I manage to get my iPod working. Once podsleuth works, Banshee picks up the iPod perfectly fine.
Comment 4 David Nielsen 2008-09-04 00:58:41 EDT
Now it works, the only change is that in between the last time I tried unplugging, rebooting and plugging is that the machine has been powered off entirely.. odd..

Now to break iPod support..
Comment 5 Fedora Update System 2008-09-04 02:17:26 EDT
podsleuth-0.6.2-3.fc9 has been submitted as an update for Fedora 9.
Comment 6 Fedora Update System 2008-09-04 02:18:17 EDT
podsleuth-0.6.2-3.fc8 has been submitted as an update for Fedora 8.
Comment 7 Fedora Update System 2008-09-24 20:03:45 EDT
podsleuth-0.6.2-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-09-24 20:13:14 EDT
podsleuth-0.6.2-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.