This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 460999 - Internet access is FUBAR (charter com. 5Gb service, direct from cable modem to NIC card). Ifup eth0 hangs, dhclient hangs, ping hangs. Ditto when installing opensuse v? or slackware 12.0. Ubuntu 7.04 works flawlessly out of the box with this though.
Internet access is FUBAR (charter com. 5Gb service, direct from cable modem t...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 04:58 EDT by Raymond Jennings
Modified: 2009-07-14 10:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 10:21:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raymond Jennings 2008-09-03 04:58:12 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.16) Gecko/20061201 Firefox/2.0.0.16 (Ubuntu-feisty)

ISP: Charter Communications
Network hardware topology:

Wall cable socket <-> coax <-> splitter (other fork is to a VoIP phone) <-> coax <-> cable modem <-> ethernet patch cable <-> NIC (a tulip ethernet card)

Specifically, all I get is some sort of an IP address, heaven knows how.  ifup eth0 hangs during DHCPDISCOVER, and ping refuses to work.

Also, I get a receive error racked up on ifconfig's report of eth0, about once every 5 seconds.

Here's what's odd.  Fresh installation of Ubuntu 7.04 (Feisty Fawn) works completely flawlessly.  A simple "dhclient eth0" in rc.local and everything is aOK.

Another oddball thing:  Booting into ubuntu, then chrooting into fedora and using fedora's binaries and libs (bind mounted the /dev and /proc dirs into the chroot), everything works just fine...  Chrooting into ubuntu from fedora, and it goes kablooey.  Effectively, ubuntu is running in the background and provides the kernel and devices (through said bind mounts), yet I am able to switch on my internet as if I had installed fedora...except with ubuntu as a supervisor it works.

I have ZERO errors under ubuntu, so I doubt I have bad hardware.

Strangely, fedora 9 isn't the only one to crap out with my internet conection.  Slackware 12.0 and opensuse (can't remember version) also fail to work out of the box with my internet, no matter how many times I ifconfig/ifup/ifdown my ethernet adapter.

Straight install of ubuntu is the only way I could get my internet to work at all.  Not so much as single ping worked on any of the other three.

Internet also works under ubuntu when it's itself running under Xen.

Interesting test:  Run ubuntu with xen, and bootstrap a fedora 9 guest, and test the guest.

Interesting information:  Only difference I found between the fedora install and the ubuntu install was the output of the "route" command.  One of the metrics was different...the ubuntu metric in question (2nd on the list) was 1000, whereas in fedora, it was 0.  Everything else (output of ifconfig, /etc/resolv.conf) was IDENTICAL for both systems.

Reproducible: Always

Steps to Reproduce:
1.  Install fedora 9, default options
or... use fedora 9 rescue mode and then chroot into the system.
2.  ifup eth0
3.  ping a pingable IP address (problem isn't in the DNS)
Actual Results:  
# ifdown eth0
(blah, releasing)
# ifup eth0
DHCPREQUEST
(repeats a few times)

Unable to determine IP information (or something like that)

# ping www.google.com
(hangs)

# ping 4.2.2.2
(hangs)

# ping ntp.ubuntu.com
(hangs)

# ping (my assigned IP address)
(hangs)


Expected Results:  
# ifup eth0
(blah)
DHCPDISCOVER blah...
DHCPOFFER blah...
DHCPREQUEST blah...
DHCPACK blah...

# ping www.google.com
(blah

Installing ubuntu solves every single problem, even if I later chroot into the fedora 9 system on my other hard drive...which was previously installed and which itself has internet trouble I boot it directly instead of booting ubuntu and then chrooting to fedora.

Since a chroot is inherited, I was using fedora's entire system, with the only difference being in the active kernel.
Comment 1 Raymond Jennings 2008-09-03 05:04:21 EDT
I really am at a loss on how to categorize this one.  I checked the category list for ifconfig, but no luck.  Either there is no such category or I am blind.

Also, the chroot into my fedora system from my ubuntu system worked even if I ifdown'ed in ubuntu, and then ifup'ed in fedora.  

Given also that one other distro worked perfectly, and two others had the EXACT same problem, I'm guessing its something general.  Given the presence of *apparent* hardware problems, I figured it could be a driver issue.  Please recategorize this if needed.

Any questions asked about my installed system will take at least 24 hours to answer, since to answer them I will need to reinstall my system.  I only have one computer, and it currently has Ubuntu.  I am 99.993 percent certain my hardware works, since Ubuntu has ZERO complaints of any sort.
Comment 2 Bug Zapper 2009-06-09 22:36:35 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-07-14 10:21:17 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.