This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 461027 - Boot fails on x86_64 with / on software raid
Boot fails on x86_64 with / on software raid
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 11:02 EDT by John Ellson
Modified: 2008-09-14 11:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-14 11:41:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
photo of boot screen (83.32 KB, image/jpeg)
2008-09-03 11:02 EDT, John Ellson
no flags Details

  None (edit)
Description John Ellson 2008-09-03 11:02:27 EDT
Created attachment 315651 [details]
photo of boot screen

Description of problem:
Boot fails  (has been failing with all 2.6.27 kernel for perhaps the past month).

System is x86_64 dual core.  With / on a software raid0 drive.

One of the error messages on the boot screen says:
   mkrootdev: could not determine nfs root target.
but root isn't nfs.

The system boots just fine with kernel-2.6.25.14-108.fc9.x86_64

Version-Release number of selected component (if applicable):
kernel-2.6.27-0.297.rc5.git2.fc10.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Reboot
2.
3.
  
Actual results:
See attached boot screen photo.

Expected results:


Additional info:
Comment 1 John Ellson 2008-09-13 08:16:07 EDT
kernel-2.6.26.3-29.fc9.x86_64  also fails on this machine.
( I changed Fedora version of this bz to 9 to reflect this. )

kernel-2.6.25.14-108.fc9.x86_64 is OK.


I'm not seeing the "mkrootdev: could not determine nfs root target"
but it still isn't mounting / from a software raid device.
Comment 2 John Ellson 2008-09-14 11:41:11 EDT
It seems that my problem was caused by installing ltsp-client on the server.
See BZ#462228

Works OK now.

Note You need to log in before you can comment on or make changes to this bug.