Bug 461029 - [RHEL-5.2] IRQ X: nobody cared, Disabling IRQ #X (interrupts shared?)
[RHEL-5.2] IRQ X: nobody cared, Disabling IRQ #X (interrupts shared?)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Justin M. Forbes
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 11:16 EDT by Flavio Leitner
Modified: 2011-01-24 18:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-29 11:25:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flavio Leitner 2008-09-03 11:16:03 EDT
Description of problem:

On Sprucewood machine running RHEL 5.2 x86 xen kernel with one network
adapter(Intel PRO/1000 PT Dual Port 39y6126) installed. If we bring up the
second interface of Intel NIC like this: "ifconfig eth3 up", then the error
message appears in the log file:

irq 20: nobody cared (try booting with the "irqpoll" option)
[<c04478aa>] __report_bad_irq+0x2b/0x69
[<c0447a9b>] note_interrupt+0x1b3/0x1ec
[<c04470f5>] handle_IRQ_event+0x49/0x51
[<c0447198>] __do_IRQ+0x9b/0xd6
[<c0406e6e>] do_IRQ+0x93/0xae
[<c0549913>] evtchn_do_upcall+0x64/0x9b
[<c04055d9>] hypervisor_callback+0x3d/0x48
[<c0408632>] raw_safe_halt+0x8c/0xaf
[<c040321a>] xen_idle+0x22/0x2e
[<c0403339>] cpu_idle+0x91/0xab
[<c06eb9f5>] start_kernel+0x37a/0x381
=======================
handlers:
[<ee2393b7>] (e1000_intr+0x0/0xe7 [e1000e])
Disabling IRQ #20

Version-Release number of selected component (if applicable):
2.6.18-92.el5xen #1 SMP i686 GNU/Linux
Machine Type = x3500 sprucewood ref.5, 7977-42Z

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 5.2 x86 xen kernel on Sprucewood advanced ref.5 machine 
with Intel Network card (PRO/1000 PT Dual Port 39y6126) installed.

2. Booting into xen kernel, type command "ifconfig eth3 up" (eth3 is 
the second port of Intel NIC), then the error message shows up in 
the log file.


Additional info:
Passing 'noirqdebug' to dom0 kernel workaround this issue indicating 
that this appears to be fixed by the patch posted at:
http://lists.xensource.com/archives/html/xen-devel/2006-06/msg00066.html
Comment 1 Chris Lalancette 2008-10-21 16:37:27 EDT
Looks like a problem, but I don't agree with the last statement; the patch there was never accepted upstream, but it's replacement was.  The thing is, we already have the replacement in 5.2, so it must be something else.

Chris Lalancette
Comment 2 Issue Tracker 2009-02-09 09:55:53 EST
------- Comment From anoop.vijayan@in.ibm.com 2009-02-07 22:33 EDT-------
Redhat, FYI, This issue is also noticed in 5.3 GA. Thanks!


This event sent from IssueTracker by jkachuck 
 issue 192002
Comment 5 Justin M. Forbes 2009-09-29 11:25:53 EDT
It appears this issue was resolved in RHEL 5.4

Note You need to log in before you can comment on or make changes to this bug.