Bug 461031 - cannot find the boot catalog directory 'isolinux'
cannot find the boot catalog directory 'isolinux'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 11:26 EDT by John Reiser
Modified: 2013-01-09 20:51 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 11:48:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fedora10/logs/i386.log (975.23 KB, text/plain)
2008-09-03 11:26 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2008-09-03 11:26:23 EDT
Created attachment 315653 [details]
Fedora10/logs/i386.log

Description of problem: pungi aborts, complaining about isolinux.


Version-Release number of selected component (if applicable):
pungi-2.0.4-1.fc10.noarch
genisoimage-1.1.8-1.fc10.i386

How reproducible: haven't tried


Steps to Reproduce:
1.pungi -c /usr/share/pungi/rawhide-fedora.ks --destdir=/data/Fedora10 --name Fedora --ver 10 --nosource

2.
3.
  
Actual results:
  [snip]
Scanning /data/Fedora10/10/i386/os/images
Excluded by match: /data/Fedora10/10/i386/os/repoview
genisoimage: Uh oh, I cant find the boot catalog directory 'isolinux'!

Traceback (most recent call last):
  File "/usr/bin/pungi", line 192, in <module>
    main()
  File "/usr/bin/pungi", line 106, in main
    mypungi.doCreateIsos(split=opts.nosplitmedia)
  File "/usr/lib/python2.5/site-packages/pypungi/__init__.py", line 1027, in doCreateIsos
    pypungi.util._doRunCommand(mkisofs + extraargs, self.logger)
  File "/usr/lib/python2.5/site-packages/pypungi/util.py", line 36, in _doRunCommand
    raise OSError, "Got an error from %s: %s" % (command[0], err)
OSError: Got an error from /usr/bin/mkisofs: Warning: creating filesystem that does not conform to ISO-9660.
I: -input-charset not specified, using utf-8 (detected in locale settings)
genisoimage 1.1.8 (Linux)
Scanning /data/Fedora10/10/i386/os
Scanning /data/Fedora10/10/i386/os/Packages
Scanning /data/Fedora10/10/i386/os/repodata
Scanning /data/Fedora10/10/i386/os/images
Excluded by match: /data/Fedora10/10/i386/os/repoview
genisoimage: Uh oh, I cant find the boot catalog directory 'isolinux'!


Expected results: no complaint; succesful completion of compose operation.


Additional info: will attach full log file (998638 bytes)
Comment 1 Jesse Keating 2008-09-03 11:48:13 EDT
Your problem is clear in the logs:

Wed Sep 3 08:03:57 PDT 2008 Expanding packages...
gfs2-utils-2.99.08-1.fc10.i386 from anaconda-mirrorlistrepo-1 has depsolving problems
  --> Missing Dependency: libvolume_id.so.0 is needed by package gfs2-utils-2.99.08-1.fc10.i386 (anaconda-mirrorlistrepo-1)
Error: Missing Dependency: libvolume_id.so.0 is needed by package gfs2-utils-2.99.08-1.fc10.i386 (anaconda-mirrorlistrepo-1)
ERROR: could not install packages
Aborting instroot creation...


Rawhide has broken deps, it happens.

Note You need to log in before you can comment on or make changes to this bug.