This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 461032 - [nvidia] openoffice.org crashes, when closing tab in Firefox with a document inside
[nvidia] openoffice.org crashes, when closing tab in Firefox with a document ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 11:28 EDT by Daniel Novotny
Modified: 2008-09-04 10:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-04 10:31:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash report (5.62 KB, text/plain)
2008-09-04 09:44 EDT, Daniel Novotny
no flags Details

  None (edit)
Description Daniel Novotny 2008-09-03 11:28:38 EDT
Description of problem:
one document opened "normally" from hard drive (openoffice.org /path/to/document.sxw), another one opened in the Firefox by clicking a link on a webpage (this opens in a plugin inside Firefox by default on F9)

after reading the document on the web page I closed the firefox tab: this caused oo.org to crash and the changes to the "normally" edited document (/path/to/document.sxw) were lost

the error message in the terminal is:


(soffice:12274): Gdk-WARNING **: GdkWindow 0x5403186 unexpectedly destroyed
X-Error: BadDrawable (invalid Pixmap or Window parameter)
	Major opcode: 70 (X_PolyFillRectangle)
	Resource ID:  0x5403186
	Serial No:    89374 (89374)
These errors are reported asynchronously,
set environment variable SAL_SYNCHRONIZE to 1 to help debugging


(setting the environmental variable, however, does not reveal any more info)


Version-Release number of selected component (if applicable):
openoffice.org-core-2.4.1-17.4.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. open one document from hard drive
2. open another document on Web using Firefox
3. close the Firefox tab with the document
  
Actual results:
openoffice.org will crash and the changes to the document from hard drive are lost

Expected results:
after closing the Firefox tab, the document on the hard drive should be still opened in openoffice

Additional info:
Comment 1 Caolan McNamara 2008-09-03 11:52:44 EDT
Is this 100% reproducible for you ? Because after toggling on the mozilla-plugin option in OOo, then opening a simple document locally and using

http://www.oasis-open.org/committees/download.php/25054/07-08-22-MetaData-Examples.odt

as the remote for-plugin document in firefox, then closing the tab in firefox doesn't reproduce this
Comment 2 Caolan McNamara 2008-09-03 11:57:34 EDT
can you also run:

/usr/lib/openoffice.org/program/crash_report -stack /dev/null

to get some info, seeing as this is an XError exit rather than a crash.
Comment 5 Daniel Novotny 2008-09-03 13:55:43 EDT
after comment #1, googling etc I consider this appears only on very complex documents (by Murphy's law all the ones I tried to view before I filed the bug report): feel free to close it as WORKSFORME if you think the issue is too unlikely to encounter
Comment 6 Caolan McNamara 2008-09-04 09:30:45 EDT
Could you try and attach the output of

/usr/lib/openoffice.org/program/crash_report -stack /dev/null

because I'm still having no success in reproducing, and I'd like to have a look at the desktop environment settings and X settings.
Comment 7 Daniel Novotny 2008-09-04 09:44:32 EDT
Created attachment 315756 [details]
crash report
Comment 8 Daniel Novotny 2008-09-04 09:45:02 EDT
ok, here it goes
Comment 9 Caolan McNamara 2008-09-04 10:31:26 EDT
Aha, you fell into my carefully constructed trap :-)

(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so

The closed-source nvidia drivers are notorious for their presence in many mysterious bugs

try googling for "X_PolyFillRectangle nvidia" and see if there is any suggested solutions.

You can always try sticking 

export SAL_IGNOREXERRORS=1 

into the top of your /usr/lib/openoffice.org/program/soffice to see if ignoring the errors will let you muddle through.

Just on the off-chance that its a generic gl desktop thing I tried with the intel driver with desktop effects enabled, and nothing weird-ass occurred for me there. 

So I'm going to unfortunately heap blame on nvidia unless its reproducible with a free driver

Note You need to log in before you can comment on or make changes to this bug.