Bug 461044 - Hercules patch to boot kernel >= 2.6.25
Hercules patch to boot kernel >= 2.6.25
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hercules (Show other bugs)
9
s390x Linux
high Severity high
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2008-09-03 12:21 EDT by Brad Hinson
Modified: 2008-11-05 23:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 23:07:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Makefile patch (425 bytes, patch)
2008-09-03 12:21 EDT, Brad Hinson
no flags Details | Diff
CVS rebase patch (3.86 MB, patch)
2008-09-04 12:10 EDT, Brad Hinson
no flags Details | Diff

  None (edit)
Description Brad Hinson 2008-09-03 12:21:43 EDT
Created attachment 315661 [details]
Makefile patch

Description of problem:
The following patch is necessary to boot kernel >= 2.6.25 under hercules.


Version-Release number of selected component (if applicable):
hercules-3.05-5
Comment 1 Matthias Saou 2008-09-04 10:42:36 EDT
Could you give a bit more information as to what removing the zzsacard.bin file from the package actually achieves? Won't anything potentially break once it's gone? Is this just a workaround until a cleaner solution is found?

I'm willing to trust you on this one, but a bit more details would be nice :-)
Comment 2 Brad Hinson 2008-09-04 12:10:35 EDT
Created attachment 315772 [details]
CVS rebase patch

We also need the hercules-3.05-cvs-rebase.patch patch file. It updates
hercules to the current cvs code level.

The patches have to be applied in the following order:

Patch0: hercules-3.05-cvs-rebase.patch
Patch1: hercules-3.05-make.patch

Here is a diff between the old and the new spec-file

--- /root/hercules/hercules.spec.orig   2008-08-26 15:55:32.000000000 -0400
+++ /usr/src/redhat/SPECS/hercules.spec 2008-09-03 09:54:00.000000000 -0400
@@ -10,9 +10,10 @@ Source1: hercules.cnf
 Source2: hercules-run
 Source3: README-rpm
 Source4: generic.prm
-Patch0: hercules-3.05-open.patch
+Patch0: hercules-3.05-cvs-rebase.patch
+Patch1: hercules-3.05-make.patch
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
-BuildRequires: bison, zlib-devel, bzip2-devel
+BuildRequires: bison, zlib-devel, bzip2-devel autoconf automake
 Obsoletes: hercules-docs <= 3.01
 
 %description
@@ -26,7 +27,10 @@ printer-keyboard, 3270 terminal, and 328
 
 %prep
 %setup -q
-%patch0 -p1 -b .open
+%patch0 -p1
+%patch1 -p1
+chmod +x autogen.sh
+./autogen.sh
 # Get the modules in the right place (lib64 on 64bit archs)
 sed -i 's|\${DESTPREFIX}/lib/|%{_libdir}/|g' configure*
 # Scripts to be looked at, not executed from the docs

---

I'll get more technical details on why this is needed shortly.
Comment 3 Brad Hinson 2008-09-05 11:25:14 EDT
Hi Matthias,

the zzsacard.bin file is removed (in the second patch) , because it 
currently  prevents hercules from compiling. 

The file actually contains the  zzsa stand alone editor (see
http://www.cbttape.org/~jjaeger/zzsa.html) which can be ipled (booted)
without an installed operating system. I have no clue who really uses this.
Afaik most of the people just run Linux inside hercules.

As far as we have seen the removal of zzsacard.bin does not break anything
else. 

The first patch updates hercules to the current cvs code base. This is 
needed to make hercules usable for Linux Kernels >= 2.6.25.

A public discussion about this can be found here:
http://www.nabble.com/Anyone-has-a-clue-(recent-Linux-kernels-fails-to-boot-under-hercules)-td17304105.html

I tried to backport all the necessary changes to the hercules 3.0.5 code
base, but gave up after 6 patches when I still was far away from  making
it work.

To rebase the package to the current cvs code level and to modify a
Makefile can obviously be regarded as a hack, but currently this seems
to be the only way to temporary work around this and to get it working
in fc9 and fc10  until a cleaner solution is found.
Comment 4 Fedora Update System 2008-10-09 10:47:47 EDT
hercules-3.05-7.20081009cvs.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/hercules-3.05-7.20081009cvs.fc9
Comment 5 Fedora Update System 2008-10-09 12:14:41 EDT
hercules-3.05-7.20081009cvs.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/hercules-3.05-7.20081009cvs.fc8
Comment 6 Fedora Update System 2008-10-15 22:06:57 EDT
hercules-3.05-7.20081009cvs.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hercules'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8833
Comment 7 Fedora Update System 2008-10-15 22:11:35 EDT
hercules-3.05-7.20081009cvs.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hercules'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8875
Comment 8 Fedora Update System 2008-11-05 23:07:36 EST
hercules-3.05-7.20081009cvs.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2008-11-05 23:09:33 EST
hercules-3.05-7.20081009cvs.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.