Bug 461045 - Segfault in openoffice when clicking on a URL [NEEDINFO]
Segfault in openoffice when clicking on a URL
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-vfs2 (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ondrej Holy
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 12:28 EDT by Dave Malcolm
Modified: 2014-06-02 09:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:20:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (dmalcolm)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 84676 None None None Never

  None (edit)
Description Dave Malcolm 2008-09-03 12:28:01 EDT
Description of problem:
Segfault upon double-clicking on a URL in a Writer document.  Crash window appeared, with text to copy and paste into a bug report - see below.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.4-5.4.17
openoffice.org-writer-2.0.4-5.4.17
neon-0.25.5-5.1
gnome-vfs2-2.16.2-4.el5

How reproducible:
Unable to reproduce

Additional info:
(I)    x.org loaded video driver of...
(II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
(II) Loading /usr/lib/xorg/modules/drivers/atimisc_drv.so
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.1-52.el5-i386
(V)    kernel is: Linux 2.6.18-8.el5xen #1 SMP Fri Jan 26 14:42:21 EST 2007 i686 i686 i386
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.4.17-i386
(VII)  depth of root window:    24 planes
(VIII) accessibility is: false
...start sestatus details ...
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 21
Policy from config file:        targeted
...end sestatus details ...
...start stackreport details ...
0x5119ee8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x22ee8
0x511ab7b: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x23b7b
0x966420:  + 0x420 (__kernel_sigreturn + 0x0)
0x4df1685e: /usr/lib/libneon.so.25 + 0x985e (ne_session_create + 0x13e)
0x301e84b: /usr/lib/gnome-vfs-2.0/modules/libhttp.so + 0x884b
0x301ec61: /usr/lib/gnome-vfs-2.0/modules/libhttp.so + 0x8c61
0x30206dc: /usr/lib/gnome-vfs-2.0/modules/libhttp.so + 0xa6dc
0xa3b135: /usr/lib/libgnomevfs-2.so.0 + 0x18135 (gnome_vfs_get_file_info_uri_cancellable + 0x102)
0xa56818: /usr/lib/libgnomevfs-2.so.0 + 0x33818 (gnome_vfs_get_file_info_uri + 0x33)
0xa567c8: /usr/lib/libgnomevfs-2.so.0 + 0x337c8 (gnome_vfs_get_file_info + 0x48)
0x575d3a: /usr/lib/openoffice.org2.0/program/ucpgvfs1.uno.so + 0xed3a (gvfs::Content::getInfo(com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&) + 0xaa)
0x57c6da: /usr/lib/openoffice.org2.0/program/ucpgvfs1.uno.so + 0x156da (gvfs::Content::getPropertyValues(com::sun::star::uno::Sequence<com::sun::star::beans::Property> const&, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&) + 0x6a)
0x57eb8f: /usr/lib/openoffice.org2.0/program/ucpgvfs1.uno.so + 0x17b8f (gvfs::Content::execute(com::sun::star::ucb::Command const&, long, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&) + 0x24f)
0x5410f05: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x1cf05
0x5414fb5: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x20fb5 (ucb::Content::getPropertyValuesInterface(com::sun::star::uno::Sequence<rtl::OUString> const&) + 0x1c5)
0x54152ed: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x212ed (ucb::Content::getPropertyValues(com::sun::star::uno::Sequence<rtl::OUString> const&) + 0x2d)
0x5415657: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x21657 (ucb::Content::getPropertyValue(rtl::OUString const&) + 0xc7)
0x5415862: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x21862 (ucb::Content::isDocument() + 0x52)
0x541b59f: /usr/lib/openoffice.org2.0/program/libucbhelper3gcc3.so + 0x2759f (ucb::Content::openWriteableStream() + 0x1f)
0x5735c4a: /usr/lib/openoffice.org2.0/program/libcomphelp4gcc3.so + 0x91c4a
0x5736f2c: /usr/lib/openoffice.org2.0/program/libcomphelp4gcc3.so + 0x92f2c (comphelper::MediaDescriptor::addInputStream() + 0x2dc)
0x9a1935: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x3a935
0x9a24a6: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x3b4a6
0x9a2c69: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x3bc69
0x9a8936: /usr/lib/openoffice.org2.0/program/libfilterconfig1.so + 0x41936
0x72b9c10: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x196c10
0x72c4dbc: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x1a1dbc
0x716df6c: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x4af6c
0x716dd80: /usr/lib/openoffice.org2.0/program/libfwk680li.so + 0x4ad80
0x66a2c14: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xafc14
0x669d028: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0xaa028
0x686afba: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x277fba
0x686b758: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x278758
0x686b7c8: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x2787c8
0x689b145: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x2a8145
0x689b0e9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x2a80e9
0x5b03226: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x282226
0xb14341: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x50341 (SalDisplay::DispatchInternalEvent() + 0xb1)
0x91aca6: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xfca6
0x91ace1: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xfce1
0x45695e1: /lib/libglib-2.0.so.0 + 0x295e1
0x456b342: /lib/libglib-2.0.so.0 + 0x2b342 (g_main_context_dispatch + 0x182)
0x456e31f: /lib/libglib-2.0.so.0 + 0x2e31f
0x456e885: /lib/libglib-2.0.so.0 + 0x2e885 (g_main_context_iteration + 0x65)
0x91cbd1: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0x11bd1
0xb157b7: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x517b7 (X11SalInstance::Yield(bool, bool) + 0x37)
0x5916708: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x95708 (Application::Yield(bool) + 0x68)
0x59167dc: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x957dc (Application::Execute() + 0x3c)
0x6fd6279: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x26279 (desktop::Desktop::Main() + 0x1779)
0x591c2ac: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9b2ac
0x591c3b5: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x9b3b5 (SVMain() + 0x35)
0x6fc7979: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x17979 (sal_main + 0x59)
0x6fc7a04: /usr/lib/openoffice.org2.0/program/libsoffice.so + 0x17a04 (main + 0x44)
0x116dec: /lib/i686/nosegneg/libc.so.6 + 0x15dec (__libc_start_main + 0xdc)
0x80484a1: /usr/lib/openoffice.org2.0/program/swriter.bin + 0x4a1
...end stackreport details ...
...start sample ldd details ...
	linux-gate.so.1 =>  (0x00494000)
	libuno_sal.so.3 => /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 (0x00110000)
	libuno_salhelpergcc3.so.3 => /usr/lib/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x002d5000)
	libstore.so.3 => /usr/lib/openoffice.org2.0/program/libstore.so.3 (0x00cb9000)
	libdl.so.2 => /lib/libdl.so.2 (0x0035f000)
	libpthread.so.0 => /lib/i686/nosegneg/libpthread.so.0 (0x00bd5000)
	libstlport_gcc.so => /usr/lib/openoffice.org2.0/program/libstlport_gcc.so (0x009ef000)
	libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x0081a000)
	libm.so.6 => /lib/i686/nosegneg/libm.so.6 (0x0042c000)
	libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x006ef000)
	libc.so.6 => /lib/i686/nosegneg/libc.so.6 (0x00495000)
	libcrypt.so.1 => /lib/libcrypt.so.1 (0x00751000)
	/lib/ld-linux.so.2 (0x003c9000)
...end sample ldd details ...
Comment 1 Caolan McNamara 2008-09-03 17:42:01 EDT
This is the same issue as

https://bugzilla.redhat.com/show_bug.cgi?id=410381
http://qa.openoffice.org/issues/show_bug.cgi?id=84676
https://bugzilla.redhat.com/show_bug.cgi?id=416571

it is technically workaround-able in OpenOffice.org (which I did for 3.0) by basically disabling the use of gnome-vfs2 for any uris which would bring the copy of the neon implementation inside gnome-vfs2 into the process space, as the public symbols of libhttp.so mixed up instead with samely named symbols of system neon as used by OOo for some other purposes

But the real problem is that an app linking to neon will work unreliably if it also uses gnome-vfs2, i.e. all the symbols listed in

nm -D /usr/lib/gnome-vfs-2.0/modules/libhttp.so | grep ne_

should not be public symbols, and/or renamed so that a gnome-vfs2 using app can also use libneon safely
Comment 2 RHEL Product and Program Management 2014-03-07 07:16:04 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.
Comment 3 RHEL Product and Program Management 2014-06-02 09:20:03 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.