Bug 461063 - NFS over GFS : fsid is required in /etc/exports; else -ESTALE
NFS over GFS : fsid is required in /etc/exports; else -ESTALE
Status: CLOSED NOTABUG
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Abhijith Das
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 18:01 EDT by Abhijith Das
Modified: 2010-01-11 22:17 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-16 06:15:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abhijith Das 2008-09-03 18:01:39 EDT
If an nfs export of gfs does not set 'fsid' in /etc/exports on the server, the client mount fails with -ESTALE.

eg:
server: 
# cat /etc/exports
/mnt/gfs   <world>(rw,wdelay,no_root_squash,sync)

client
# mount server:/mnt/gfs /mnt/nfs
mount: stale NFS file handle

when I add fsid=1 to /etc/exports, i.e
/mnt/gfs   <world>(rw,wdelay,no_root_squash,fsid=1,sync)

client mount succeeds.

Should fsid be a mandatory param for NFS over GFS?
Comment 1 Steve Whitehouse 2008-12-10 11:40:50 EST
Yes, it needs to be. We can't create filehandles from device numbers like local filesystems can, so we have this system of having to specify it. It ought to be documented though, so if its missing from the docs, then please turn this into a doc bug.

Potentially we might be able to create an ID by using the UUID or some other unique identifier in the future. The only problem being that we can never be sure that it will not be a duplicate of an existing one. The only really safe way is to get the user to specify it.

Note You need to log in before you can comment on or make changes to this bug.