Bug 461065 - RFE: GFS should accept "onerror=panic" and "onerror=withdraw" or similar mount option
RFE: GFS should accept "onerror=panic" and "onerror=withdraw" or similar moun...
Status: CLOSED DUPLICATE of bug 488499
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-utils (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: 5.5
Assigned To: Robert Peterson
Cluster QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 18:19 EDT by Vinny Valdez
Modified: 2010-01-11 22:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 09:56:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vinny Valdez 2008-09-03 18:19:13 EDT
Description of problem:
RFE: Currently the debug options seems to be the only way to cause the
system to panic on a GFS error.  The scenario I am testing is when a
cluster node loses all access to storage.  Currently it withraws, but to
ensure the system is fenced the debug option can cause it to panic.

Version-Release number of selected component (if applicable):
5.2
gfs-utils-0.1.17-1.el5


How reproducible:
Everytime

Steps to Reproduce:
1. Setup GFS
2. Remove all storage access from a node
3. System withdraws GFS, but stays operational in the cluster
  
Actual results:
If the node is running services, and cluster communications are working fine, and the services do not fail over.

Adding "debug" to the mount option allows the system to panic instead.
This causes it to fence, and everything else falls into place.

Expected results:
If a system loses access to the storage and thus GFS, it should not remain operational in the cluster.

An option to panic the node on any GFS errors as documented in the mount man page for other filesystems would be nice.  This ensures the system is fenced and services fail over.
Comment 1 Steve Whitehouse 2008-12-10 10:15:09 EST
We should probably consider doing this in GFS2 first, and the maybe back port to GFS.
Comment 3 Robert Peterson 2009-08-05 09:56:30 EDT
Now that we've decided how to handle bug #488499, and have a
working prototype patch for it, it clearly implements the RFE
in this bugzilla.  So I'm closing this bug as a duplicate of
that one.

*** This bug has been marked as a duplicate of bug 488499 ***

Note You need to log in before you can comment on or make changes to this bug.