Bug 461068 - Bad error dialog
Bad error dialog
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-03 19:00 EDT by Michael Monreal
Modified: 2008-09-18 06:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 06:49:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (9.43 KB, image/png)
2008-09-03 19:07 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2008-09-03 19:00:17 EDT
There's a dialog in PackageKit which pops up if PK cannot fetch update lists:

------------------------------------------
[ ]    PackageKit Update Applet        [x]
------------------------------------------

     Getting update lists failed

     Failed to get updates

     > More details

                                [ OK ]

------------------------------------------


1.) The dialog should not include branding names like "PackageKit" and also probably not reference applet. No big deal as the HIG asks not to use window titles for this kind of window anyway.

2.) The headline and the main dialog text are basicly the same?
Comment 1 Michael Monreal 2008-09-03 19:07:37 EDT
Created attachment 315708 [details]
Screenshot
Comment 2 Richard Hughes 2008-09-17 04:54:28 EDT
I've removed the "PackageKit" branding in commit 55eb7657ec1ccf1d4f5b5ffc9b1c61ed050955af -- I'll fix the rubbish error reporting in a minute.
Comment 3 Richard Hughes 2008-09-17 05:58:03 EDT
That method really shouldn't have failed like that -- what's the message in the "more details" box please? Thanks.
Comment 4 Michael Monreal 2008-09-17 07:20:24 EDT
"failed to get a TID: Launch helper exited with unknown return code 1"

PK version is 0.3.1 btw.
Comment 5 Richard Hughes 2008-09-17 09:57:54 EDT
Okay, there are three errors here:

1. The daemon failed to start
2. The libpackagekit library didn't recognise the error code
3. The GpkClient session code didn't have a good translation for the code

Addressing these my end:

2:

commit 3cc92e5665d57f6e597580506ef3bb501aa2cf8b
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Sep 17 14:33:24 2008 +0100

    bugfix: when we can't start the dameon from a DBUS method, emit a proper error code rather than just 'failed'

:100644 100644 cc710d6... 284be12... M  libpackagekit/pk-client.c
:100644 100644 84f1337... c53e33b... M  libpackagekit/pk-client.h
:100644 100644 df64249... 366a0e3... M  libpackagekit/pk-control.c
:100644 100644 1d46e41... f2fd0c0... M  libpackagekit/pk-control.h

3:

commit 4542d787232df61abafcd687ae03fdd88d87c48a
Author: Richard Hughes <richard@hughsie.com>
Date:   Wed Sep 17 14:53:18 2008 +0100

    bugfix: use the new CANNOT_START_DAEMON error code to display a more useful message to the user

and for 1:, I need to know what happens when you (as root) type this:

/usr/sbin/packagekitd -v

Thanks.
Comment 6 Michael Monreal 2008-09-17 11:03:05 EDT
I get a "failed to cache rpm database (1)" error.

I don't think it's worth to look into this any further as the system seems to be horribly broken (it's a test vm tracking the unstable distribution after all).

I will install a new VM when the next alpha (beta?) is out, I'm sure the error will be gone then.
Comment 7 Richard Hughes 2008-09-18 06:49:16 EDT
That means you've got a very broken rpmdb --  you can try to --rebuilddb if you are feeling lucky, but the system looks pretty hosed.

I'll close this bug, but please re-open if you can reproduce. Thanks for all your help.

Note You need to log in before you can comment on or make changes to this bug.