Bug 46109 - Problem with samba after an update
Problem with samba after an update
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-26 17:11 EDT by Need Real Name
Modified: 2007-04-18 12:34 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-03 05:17:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-06-26 17:11:07 EDT
After upgrade of a server from samba 2.0.5 to 2.0.10 samba-2.0.10-0.52
I can not mount disk any longer.
I log I have:

[2001/06/26 17:05:30, 0] lib/util_sec.c:assert_gid(72)
  Failed to set gid privileges to (-1,500) now set to (0,0) uid=(0,0)
[2001/06/26 17:05:30, 0] lib/util.c:smb_panic(2381)
  PANIC: failed to set gid

It worked before,
It also works OK with server having 2.2 kernel.
Does not work with RedHat 5.2 as a server.
samba-2.0.10-0.62 is OK, only samba-2.0.10-0.52 has this problem
when used as a server.
Comment 1 Trond Eivind Glomsrxd 2001-06-26 17:18:14 EDT
Exactly what is server and what is client, and was samba-2.0.10-0.62 running on
a RHL 5.2 system?



Comment 2 Need Real Name 2001-06-26 17:24:00 EDT
Server:
 RedHat 5.2 kernel 2.0.39, smaba from updates
samba-2.0.10-0.52
samba-client-2.0.10-0.52

Client:
RedHat 7.0 2.2.19-7.0.1 and 2.2.19-7.0.8
tried samba-2.0.8-1.7 and samba-2.0.10-0.7

Everything work OK if server is RedHat 6.1 or RedHat 7.0 
with samba from recent updates (samba-2.0.10)
With RedHat 5.2 it does not work.
Comment 3 Trond Eivind Glomsrxd 2001-06-26 17:34:02 EDT
And the message you see is on the client or on the server?
Comment 4 Need Real Name 2001-06-26 17:37:17 EDT
On the Client:
smbmount //127.0.0.1/cvs2 /mnt/ -o username=mal,uid=mal,port=53124
Password: 
tree connect failed: code 0
SMB connection failed

On the server in one log:
[2001/06/26 17:23:02, 0] lib/util_sec.c:assert_gid(72)
  Failed to set gid privileges to (-1,105) now set to (0,0) uid=(0,0)
[2001/06/26 17:23:02, 0] lib/util.c:smb_panic(2381)
  PANIC: failed to set gid

And in another log:
[2001/06/26 17:03:01, 1] smbd/files.c:file_init(216)
  file_init: Information only: requested 10000 open files, 246 are available.
[2001/06/26 17:03:01, 0] lib/util_unistr.c:load_unicode_map(435)
  load_unicode_map: filename /etc/codepages/unicode_map.850 does not exist.
Comment 5 Trond Eivind Glomsrxd 2001-06-26 17:39:14 EDT
Aron, can you reproduce this?
Comment 6 Need Real Name 2001-06-26 21:52:38 EDT
Just for information:
downgrade of samba on server (Redhat 5.2, kernel 2.0.39)
to samba-2.0.5a-2.5.2 fixes this problem.
The samba-2.0.5a-2.5.2 works OK.
Comment 7 Need Real Name 2001-06-26 21:59:18 EDT
Also note that the connection
is established via openssh tunnel
In the bug

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=38632

I gave exact description of how the connection is established.
Comment 8 Trond Eivind Glomsrxd 2001-06-26 22:31:56 EDT
So if you don't use an ssh-tunnel, there is no problem?
Comment 9 Need Real Name 2001-06-26 22:44:01 EDT
I never tried with no ssh tunnel, because the server 
is not accessable in other way. 
There is no way I can not test it without ssh-tunnel.

Also because of an error message on server
On the server in one log (from above):

[2001/06/26 17:05:30, 0] lib/util_sec.c:assert_gid(72)
   Failed to set gid privileges to (-1,500) now set to (0,0) uid=(0,0)
 [2001/06/26 17:05:30, 0] lib/util.c:smb_panic(2381)
   PANIC: failed to set gid

I do not think that the problem is ssh-related.
Why it wants to set priviledges to -1,500
My uid,gid is 500,500
Why it uses -1?

Comment 10 Need Real Name 2001-06-26 22:50:41 EDT
Also, in another case where samba uses (-1,105)
the group 105 came from configuration,
where for that share is set
force group = cvs 
(the cvs group has uid 105)

[2001/06/26 17:23:02, 0] lib/util_sec.c:assert_gid(72)
   Failed to set gid privileges to (-1,105) now set to (0,0) uid=(0,0)
 [2001/06/26 17:23:02, 0] lib/util.c:smb_panic(2381)
   PANIC: failed to set gid

Comment 11 Need Real Name 2001-06-26 23:02:09 EDT
This is share description:

[hd]
   comment = Home Directories
   browseable = no
   writable = yes
   delete readonly = yes
   create mask = 0644
   path = /home
   delete readonly = yes
   public = no

It gives error message
[2001/06/26 23:00:38, 0] lib/util_sec.c:assert_gid(72)
  Failed to set gid privileges to (-1,500) now set to (0,0) uid=(0,0)
[2001/06/26 23:00:38, 0] lib/util.c:smb_panic(2381)
  PANIC: failed to set gid

when using command

smbmount //127.0.0.1/hd /mnt/ -o username=mal,uid=mal,port=53124

user mal has 500.500 uid,gid

then for a test I changed share description:
[hd]
   comment = Home Directories
   browseable = no
   writable = yes
   force user = mal2
   force group = mal2
   delete readonly = yes
   create mask = 0644
   path = /home
   delete readonly = yes
   public = no

I added "force user" and "force group" for mal2 who has uid,gid 502.502
The error then
[2001/06/26 23:02:06, 0] lib/util_sec.c:assert_gid(72)
  Failed to set gid privileges to (-1,502) now set to (0,0) uid=(0,0)
[2001/06/26 23:02:06, 0] lib/util.c:smb_panic(2381)
  PANIC: failed to set gid


The group was set to 502, but user was not.
The glibc is glibc-2.0.7-29.4

It seems like some kind of library problem.
Why it always have uid=-1 , even "force user" does not change it.
Comment 12 Tom Diehl 2001-07-03 15:34:27 EDT
I have a 5.2 system with ALL updates done. I too am experiencing the above
described panic. All uid's and gid's are in the 601-699 range and no ssh is
involved. Downgrading to the 2.0.5a rpms fixes the problem. Let me know if you
want the config file or any other info. 

As an additional note logrotate throws errors when it runs with this version of
samba installed. I do not have the errors since I had to uninstall the 2.0.10
rpms to get samba working again. Logrotate complains about incorrect options so
I suspect it will be relatively easy to fix once the panic problems are
resolved.
Comment 13 Simon Matter 2001-07-17 07:07:16 EDT
HiI get the same errors with samba 2.0.10 on RedHat 5.2.

BTW: the sharedscripts statement in logrotate generates errors.
Comment 14 Joe Pruett 2001-07-30 17:23:47 EDT
i have found the source of this problem.  somehow the rpms were compiled on a
system that thought it supported setresuid/setresgid, which 5.2 doesn't.  i
recompiled the updated srpm on my 5.2 box and everything is working fine now.
Comment 15 Trond Eivind Glomsrxd 2001-08-09 15:05:49 EDT
Thanks for discovering the problem... samba should handle detection at runtime,
not at compile time. Will make sure it doesn't do that if we ever release
another samba for RHL 5.2
Comment 16 Joe Pruett 2001-08-09 16:40:35 EDT
i hope that you will at least recompile the existing patch.  otherwise you'll just keep getting people complaining about this.
Comment 17 Trond Eivind Glomsrxd 2001-08-09 16:55:06 EDT
Actually, there is a patch (in the 0.52) in there addressing exactly this problem...
Comment 18 Trond Eivind Glomsrxd 2001-09-20 11:49:30 EDT
Can you please try the RPMs at http://people.redhat.com/teg/samba? TIA.
Comment 19 Davide Bolcioni 2001-10-03 05:17:42 EDT
I tried samba-2.0.10-0.521.i386.rpm from the above and it works fine, including 
with Windows 2000 Workstation clients. Now please make sure the next update is 
named samba-2.0.10-1 or something like this, since autorpm does not seem to 
fully grok funny package numbers :->
Comment 20 Trond Eivind Glomsrxd 2001-10-08 14:16:30 EDT
Version numbers won't be changed - we need to keep upgrade paths working between
the various versions of the distro. The updated packages should now be available
from the updates directory.

Note You need to log in before you can comment on or make changes to this bug.