Bug 461124 - No menu for Scribus
No menu for Scribus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scribus (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-09-04 08:45 EDT by antonio montagnani
Modified: 2008-10-14 13:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-13 12:35:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2008-09-04 08:45:06 EDT
Description of problem:
No menu available for scribus after installation

Version-Release number of selected component (if applicable):
scribus-1.3.5-0.3.12419svn.fc10.i386

How reproducible:

always
Steps to Reproduce:
1.Install RPM
2.Look in Application/Office
3.
  
Actual results:
No menu for Scribus

Expected results:
Scribus should be available

Additional info:
Comment 1 John Poelstra 2008-09-08 23:03:34 EDT
I can confirm that in F9 a menu option did appear.
Comment 2 Dan Horák 2008-09-09 03:18:07 EDT
The problem is here - http://cvs.fedoraproject.org/viewvc/rpms/scribus/devel/scribus.spec?r1=1.31&r2=1.32
But the real cause is in upstream because they install only a KDE desktop file and not the global one - see toplevel CMakeLists.txt, line 680
Comment 3 Dan Horák 2008-09-09 04:38:02 EDT
related upstream bug: http://bugs.scribus.net/view.php?id=7208
Comment 4 antonio montagnani 2008-10-08 17:02:33 EDT
on another system I found the menu in Application/Other.....
Comment 5 Dan Horák 2008-10-09 14:01:33 EDT
(In reply to comment #4)
> on another system I found the menu in Application/Other.....

Antonio, what are your desktop environments - GNOME, KDE, ...? Both machines are using Rawhide?
Comment 6 antonio montagnani 2008-10-09 14:52:30 EDT
Both machine are using Rawhide, and both machine Gnome.

I have found also that on same machine where scribus missing, one user has no Gnome Images Manipulation Program (i.e. Gimp) entry (missing even in available entries in System/Preferences/Menu ...while other users have it.
And on same machine I do not have Trasbin applet to be added to bar in applet list.
I do not know whether these issues are connected (see also my messages in Development list)

Tnx
Comment 7 antonio montagnani 2008-10-09 15:07:42 EDT
forgot to say that on one machine scribus is missing for all users....
Comment 8 Dan Horák 2008-10-13 12:35:42 EDT
So new version is being built for Rawhide - scribus-1.3.5-0.5.12516svn.fc10

note for Andreas:
When the KDE-only desktop will need to be installed for some reason then we must add Requires: kde-filesystem for the ownership of /usr/share/mimelnk/application directory.
Comment 9 Kevin Kofler 2008-10-14 13:38:51 EDT
/usr/share/mimelnk is essentially obsolete. It is used for KDE 3 file associatins, but KDE 4 ignores it for file associations. And it definitely should not be used for menu entries, not in KDE 3 nor in KDE 4.

Note You need to log in before you can comment on or make changes to this bug.