Bug 461155 - "Fatal server error: lockup" with intel driver
"Fatal server error: lockup" with intel driver
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 12:35 EDT by Andrew McNabb
Modified: 2009-10-22 08:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 12:40:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log-2.4.2-1 (36.95 KB, text/plain)
2008-09-04 12:35 EDT, Andrew McNabb
no flags Details
Xorg.0.log-2.4.2-3 (30.08 KB, text/plain)
2008-09-04 12:36 EDT, Andrew McNabb
no flags Details
a working Xorg.0.log (28.96 KB, text/plain)
2008-09-04 12:58 EDT, Andrew McNabb
no flags Details

  None (edit)
Description Andrew McNabb 2008-09-04 12:35:45 EDT
Created attachment 315775 [details]
Xorg.0.log-2.4.2-1

X seems to start up correctly with the intel driver, but after a few seconds, it hangs.  The machine is still up, but the image is frozen on the screen.  The Xorg.0.log shows the message, "Fatal server error: lockup".

The attached Xorg.0.log is from xorg-x11-drv-i810-2.4.2-1.fc10.x86_64.  When I tried xorg-x11-drv-i810-2.4.2-3.fc10.x86_64.rpm, I got the following repeating error:

[mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] mieqEnequeue: out-of-order valuator event; dropping.

Let me know if there's any additional information that would be helpful.
Comment 1 Andrew McNabb 2008-09-04 12:36:24 EDT
Created attachment 315776 [details]
Xorg.0.log-2.4.2-3
Comment 2 Andrew McNabb 2008-09-04 12:58:14 EDT
Created attachment 315782 [details]
a working Xorg.0.log

It seems to work occasionally.  I'm attaching an Xorg.0.log from a working session.
Comment 3 Andrew McNabb 2008-09-04 15:48:40 EDT
I set AccelMethod to XAA and haven't seen the "Fatal server error: lockup" error since.  This isn't too surprising, since the traceback had EXA stuff in it.
Comment 4 Bug Zapper 2008-11-25 21:57:33 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.