Bug 461196 - RFE: Ship stable stable Scribus only or keep updated with SVN
RFE: Ship stable stable Scribus only or keep updated with SVN
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: scribus (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-04 16:11 EDT by Gian Paolo Mureddu
Modified: 2011-12-06 10:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 10:50:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2008-09-04 16:11:11 EDT
Description of problem:
There is a "problem" in that the currently shipped and maintained version in Fedora (1.3.4-5.fc9) is outdated and is incompatible with the latest stable (1.3.3.12) release from upstream. Also 1.3.4 has been ditched in favor of 1.3.5 in SVN. The main problem with this is that people working with Scribus on Fedora cannot share their work with others easily as the upstream project only offers (for example for Windows or Mac) the latest stable version of a build of SVN, Fedora has a old development version which makes it imposible to stay compatible with these other versions.

Version-Release number of selected component (if applicable):
scribus-1.3.4-5.fc9

The current version in Fedora, being outdate serves no purpose even to test out the latest development version of Scribus, as bugs reported against this version to upstream are invalidated due to there being another, newer version. Nor can users work in projects with others that may be using the latest stable version, as Fedora doesn't provide the stable branch either. So currently Scribus users seem to be left in "limbo". Why not provide only the stable branch, or even maybe both versions being mutually exclusive, and the SVN one through the -testing repositories, only?

1.3.4 has some bugs that won't be fixed for that particular version (See "Signal #6 crashing Scribus" bugs in upstream tracker, for example)
Comment 1 Andreas Bierfert 2008-09-05 14:37:36 EDT
The points you bring forward are all valid. I will be more than happy to upgrade to 1.3.5 as soon as it is released (see rawhide for a svn snapshot). However having 1.3.4 in f9 was bad enough (instead of 1.3.3.x) that I will not upgrade unless there is a stable release of 1.3.5.
Comment 2 Frank Cox 2009-06-19 18:57:53 EDT
The current version of Scribus that ships with Fedora 11 (1.3.5) is an unstable "beta" version.

The best explanation that I have seen for Scribus version numbering was just posted by John Culleton on the Scribus mailing list:  "1.3.5 is forever unstable. 1.3.4 is both unstable and abandoned. 1.3.3.13 is the only stable version."

Scribus 1.3.3.13 is the version that should be shipped with Scribus.  Anyone doing real work with Scribus on Fedora at this time should be using that version.
Comment 3 Dan Horák 2010-01-27 09:16:01 EST
Until the package with stable scribus 1.3.3.x passes the review process (https://bugzilla.redhat.com/show_bug.cgi?id=519135) it is available from http://fedora.danny.cz/danny/
Comment 4 Luya Tshimbalanga 2011-12-05 16:55:16 EST
This report is outdated now that 1.3.3.x is not maintained anymore.
http://wiki.scribus.net/canvas/Download
Comment 5 Luya Tshimbalanga 2011-12-05 16:59:08 EST
In addition, this package should be in sync with upstream. Fedora version is 1.3.9 while upstream is 1.4.0 release candidate. Because its ticket is about update with SVN, it should be at least with 1.5.x.

Regards
Comment 6 Dan Horák 2011-12-06 10:50:52 EST
Scribus in Fedora 15 and 16 will be updated to 1.4.0 when it's released. Until then you can get the 1.4.0rcX from http://fedora.danny.cz/danny/

Note You need to log in before you can comment on or make changes to this bug.