This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 461221 - line breaks are ignored when lines start with <replaceable> within <screen>
line breaks are ignored when lines start with <replaceable> within <screen>
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: publican-fedora (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Fearn
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 00:29 EDT by Murray McAllister
Modified: 2015-01-04 17:35 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-08 23:40:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
No line break (as expected) (12.36 KB, image/png)
2008-09-05 00:29 EDT, Murray McAllister
no flags Details
No line break. This is not expected. (13.77 KB, image/png)
2008-09-05 00:30 EDT, Murray McAllister
no flags Details
No line breaks. Not expected (32.88 KB, image/png)
2008-09-05 01:17 EDT, Murray McAllister
no flags Details

  None (edit)
Description Murray McAllister 2008-09-05 00:29:48 EDT
Created attachment 315827 [details]
No line break (as expected)

Version-Release number of selected component (if applicable):
* Red Hat Enterprise Linux Client release 5.2 (Tikanga)
* publican-fedora-0.14-0.el5
* publican-0.36-5.el5

How reproducible:
Alwayz :(

Steps to Reproduce:
1:

<screen>
<replaceable>--2008-09-05 12:06:03--</replaceable>  http://localhost/testfile
Resolving localhost... 127.0.0.1
Connecting to localhost|127.0.0.1|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 0 [text/plain]
Saving to: `testfile'

[ &lt;=&gt;                                    ] 0           --.-K/s   in 0s
<replaceable>2008-09-05 12:06:03</replaceable> (0.00 B/s) - `testfile' saved [0/0]
</screen>

Results: see 1.png

2:

<screen>
<replaceable>--2008-09-05 12:06:03--</replaceable>  http://localhost/testfile
Resolving localhost... 127.0.0.1
Connecting to localhost|127.0.0.1|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 0 [text/plain]
Saving to: `testfile'

[ &lt;=&gt;                                    ] 0           --.-K/s   in 0s






<replaceable>2008-09-05 12:06:03</replaceable> (0.00 B/s) - `testfile' saved [0/0]
</screen>

Results: see 2.png


Expected results:
A line break between "[ &lt;=&gt;                                    ] 0           --.-K/s   in 0s" and the date on the following line.

I do not have to use replaceable here, so feel free to close...
Comment 1 Murray McAllister 2008-09-05 00:30:31 EDT
Created attachment 315828 [details]
No line break. This is not expected.
Comment 2 Jeff Fearn 2008-09-05 00:44:06 EDT
Actually the bug here is because the previous line is being line wrapped due to it's length. Introducing a non-verbatim element at this point introduces an interesting question as to what the correct result should be.

If this is in HTML then it is a borwser issue.

If it id PDF then it may be a tool chain issue.

Please include such information when reporting visual issues as they varying outputs have unrelated tooling issues.
Comment 3 Murray McAllister 2008-09-05 01:17:10 EDT
Previous screenshots are HTML in Firefox 3.0.1 (the naughty, upstream, non-packaged version).

Same issue occurs in PDF (viewed with evince-0.6.0-8.el5).
Comment 4 Murray McAllister 2008-09-05 01:17:51 EDT
Created attachment 315830 [details]
No line breaks. Not expected
Comment 5 Murray McAllister 2008-09-05 01:20:09 EDT
Bah. comment #4 is from PDF (evince-0.6.0-8.el5)
Comment 6 Jeff Fearn 2008-09-08 23:40:21 EDT
Non-verbatim tags are fully entitled to munch you white space, even when nested inside verbatim tags.

Note You need to log in before you can comment on or make changes to this bug.