Bug 461229 - buildinstall creates bloated install disks
buildinstall creates bloated install disks
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 03:54 EDT by Jerry Vonau
Modified: 2013-01-09 20:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 18:49:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to correct the issue (2.29 KB, patch)
2008-09-05 14:02 EDT, Jerry Vonau
no flags Details | Diff

  None (edit)
Description Jerry Vonau 2008-09-05 03:54:42 EDT
Description of problem:
pungi and revisor both create dvd.iso and disc1.iso with the boot.iso in /images

Version-Release number of selected component (if applicable):
11.4.0.82

How reproducible:
use pungi/revisor to spin an install set, look in /images on the spun images.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
slimmer dvd/disc1, without boot.iso in it.

Additional info:
Haven't checked to see if rawhide does that still.
Comment 1 Jesse Keating 2008-09-05 13:38:23 EDT
I think this is done on purpose, so that if you get the media at a show or via a distributor, the smaller images are available for your use.  However I'm just guessing, and will ask some folks who have been around longer than I have regarding this.
Comment 2 Jerry Vonau 2008-09-05 14:02:04 EDT
Created attachment 315923 [details]
patch to correct the issue

boot.iso in disc1? the disk is bootable......
Comment 3 Jesse Keating 2008-09-05 14:36:57 EDT
erm, it's so that you can take the boot.iso off the physical media and use it for other systems.  Jeremy Katz claims that this was done by design, but might be time to re-think.  CCing him.
Comment 4 John Reiser 2008-09-13 17:08:38 EDT
It is common for some laptops and servers to boot only from hard disk, network, or internal CD drive; and not from DVD.  Such machines typically can handle a DVD on an external drive via USB2.0 once the OS is running, but cannot boot from USB.  Thus a DVD by itself cannot be booted.  Instead, burn boot.iso (netinst.iso) to a CD, then boot from that.

It is a convenience to include boot.iso (netinst.iso) on the DVD, so that there is only one file to download (but still has all the data for all use cases), and only one file to keep track of (until installing on a machine that cannot boot DVD.)  So far, a 4.7GB DVD can afford to include the 120MB boot.iso (netinst.iso) image file.

If it works to install via boot from CD/disc1 [in constrast to boot.iso (netinst.iso)] and get all the non-boot data from DVD via USB2.0, then I agree that including boot.iso (netinst.iso) on CD/disc1 is redundant.  But please do not remove boot.iso (netinst.iso) from DVD, at least as long as there isn't a space crunch on a single 4.7GB DVD.
Comment 5 Jerry Vonau 2008-09-13 18:37:46 EDT
Think this becomes an issue of who should pay the extra price in bandwidth for the "convenience", those who can boot the dvd, or those who can't. With the current layout everybody pays the price, where as the extra cost should only be incurred by those who need the boot.iso. What really is needed is a step backwards, a striped down boot.iso for the dvd/disc set, stage2 is not required to boot an install, just needs to be present once the install method is chosen. 

Hum... As a possible solution, could you not script the making of a "boot.iso" based on what is on the dvd/disc1 locally once you have the media? /isolinux and /images is about all that is needed to re-create a boot.iso. Adding the ability to add a ks file at that point would be bonus points, for whose who re-roll the boot.iso to include one.
Comment 6 Jesse Keating 2009-02-05 18:49:37 EST
I've gone ahead and stripped boot.iso from CD1 and DVD.  Will be in the next build of pungi.

Note You need to log in before you can comment on or make changes to this bug.