Bug 461241 - (utilities-lvm) Icon reference in .desktop file contains full path to icon file and extension (.png)
Icon reference in .desktop file contains full path to icon file and extension...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 05:37 EDT by Luya Tshimbalanga
Modified: 2009-10-30 08:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-30 05:23:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luya Tshimbalanga 2008-09-05 05:37:31 EDT
Description of problem:
Similar to other system-config*, icon reference in .desktop file contains file extension (.png) which prevents
effectively theming it, e.g. if the used icon theme is based solely on SVGs

Version-Release number of selected component (if applicable):
system-config-lvm-1.1.4-1.0.fc9,noarch

Additional info:
Just dropping the extension is fine (i.e. to Icon=system-config-lvm), but
it
would be even better if the icon name could be changed to something more
general and follow the Icon Naming Guidelines [1]. I'd suggest
preferences-network-boot.

Also, as the icon is used in the application itself, it would be nice to look
it up the correct way [2]. GTK has already prepared look-up functions for that,
so the implementation should not be hard. Patch attached to bug #454402 might
be helpful.

[1]
http://standards.freedesktop.org/icon-naming-spec/icon-naming-spec-latest.html#guidelines

[2]
http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html#icon_lookup
Comment 1 Martin Sourada 2008-09-05 05:47:17 EDT
The problem is slightly worse than just extension - in this case the .destkop file contains full path to icon (or contained the last time I checked) which prevents theming completely. Correct way is to install the icon into hicolor icon theme and use only icon name (without extension) in the .desktop file.
Comment 2 Marek Grac 2009-10-30 05:23:52 EDT
System-config-lvm is entering maintainance-only mode and whole package will be deprecated. We do not plan active development, only major bugs will be fixed.
Comment 3 Luya Tshimbalanga 2009-10-30 06:38:33 EDT
Which package will supersede system-config-lwm?
Comment 4 Marek Grac 2009-10-30 08:22:37 EDT
Application that is part of GNOME (if I'm right it is gnome-disk-utility), it does not support lvm yet but that will be fixed soon.

Note You need to log in before you can comment on or make changes to this bug.