Bug 461285 - Any use of Class::MethodMaker spews pages of warnings to console
Any use of Class::MethodMaker spews pages of warnings to console
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Class-MethodMaker (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gregorovic
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 12:12 EDT by Daniel Berrange
Modified: 2008-09-24 20:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 20:22:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2008-09-05 12:12:44 EDT
Description of problem:
Since the upgrade to perl 5.10, any application which uses Class::MethodMaker spews pages of warnings to stderr. This makes such apps essentially unusable if they're console based

See this demo:

# cat > cmm.pl <<EOF
package Foo;

use Class::MethodMaker
    new_with_init => "new",
    get_set => [qw(bar)];

sub init {
    my $self = shift;

    $self->bar("hello");
}

package main;

my $foo = Foo->new;

print $foo->bar, "\n";

$foo->bar("world");

print $foo->bar, "\n";
EOF



Version-Release number of selected component (if applicable):
perl-5.10.0-31.fc9.i386
perl-Class-MethodMaker-2.11-1.fc9.i386


How reproducible:
Always

Steps to Reproduce:
1. perl cmm.pl
2.
3.
  
Actual results:
Name " Foo::bar" used only once: possible typo at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/Class/MethodMaker/Engine.pm line 781.
Name " Foo::get_bar" used only once: possible typo at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/Class/MethodMaker/Engine.pm line 781.
Name " Foo::new" used only once: possible typo at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/Class/MethodMaker/Engine.pm line 781.
Name " Foo::bar_reset" used only once: possible typo at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/Class/MethodMaker/Engine.pm line 781.
Name " Foo::bar_isset" used only once: possible typo at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/Class/MethodMaker/Engine.pm line 781.
Name " Foo::set_bar" used only once: possible typo at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/Class/MethodMaker/Engine.pm line 781.
Name " Foo::clear_bar" used only once: possible typo at /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi/Class/MethodMaker/Engine.pm line 781.
hello
world

Expected results:
hello
world

Additional info:
Comment 1 Daniel Berrange 2008-09-05 12:14:22 EDT
This is tracked upstream in:

http://rt.cpan.org/Public/Bug/Display.html?id=35840


which indicates it is fixed in version 2.12 of Class::MethodMaker.  I'd request that Fedora just upgrade to 2.12, since the diff from 2.11 to 2.12 contains only the fix for this bug

http://search.cpan.org/diff?from=Class-MethodMaker-2.11&to=Class-MethodMaker-2.12
Comment 2 Ralf Corsepius 2008-09-05 12:32:37 EDT
OK, now the maintainer of this package still seem to be AWOL, 
I'll look into this and try to push a updates to rawhide rsp. testing.
Comment 3 Ralf Corsepius 2008-09-05 12:35:47 EDT
OK, you were faster, I will stop working on this and leave this issue to you.
Comment 4 Daniel Berrange 2008-09-05 12:40:26 EDT
Yep, just spoke to the maintainer directly after I noticed he's a RH guy and he said to go ahead & fix it...
Comment 5 Ralf Corsepius 2008-09-05 13:03:49 EDT
As he has ignored this package for years, I recommend him to abandon maintainership.
Comment 6 Fedora Update System 2008-09-05 13:34:55 EDT
perl-Class-MethodMaker-2.12-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/perl-Class-MethodMaker-2.12-1.fc9
Comment 7 Dennis Gregorovic 2008-09-05 14:05:53 EDT
I've gone and released my ownership of this package in the pkgdb.  I don't use this library anymore, so it doesn't make sense for me to be the maintainer.
Comment 8 Daniel Berrange 2008-09-05 14:31:43 EDT
I grabbed ownership of F8/9/rawhide, but not EPEL. Ralf if you or anyone you know wants to co-maintain just request it in pkgdb & i'll approve
Comment 9 Ralf Corsepius 2008-09-09 02:54:42 EDT
(In reply to comment #8)
Thanks, I just applied for co-maintainership.
Comment 10 Fedora Update System 2008-09-11 13:13:39 EDT
perl-Class-MethodMaker-2.12-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Class-MethodMaker'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-7956
Comment 11 Fedora Update System 2008-09-24 20:22:52 EDT
perl-Class-MethodMaker-2.12-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.