Bug 461289 - apparent file system corruption of snapshot fs
apparent file system corruption of snapshot fs
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On: 211235
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 12:40 EDT by Corey Marthaler
Modified: 2010-01-11 22:54 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 12:56:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Corey Marthaler 2008-09-05 12:42:10 EDT
Cloning this bug as it's now being seeing on RHEL5

SCENARIO - [fs_io_A]
Create snapshots of origin with fs data, and then verify that data on snapshots
Making origin volume
Placing an ext filesystem on origin volume
mke2fs 1.39 (29-May-2006)
Mounting origin volume

Writing files to /mnt/origin
checkit starting with:
CREATE
Num files:          500
Random Seed:        12647
Verify XIOR Stream: /tmp/checkit_origin_1
Working dir:        /mnt/origin

Checking files on /mnt/origin
checkit starting with:
VERIFY
Verify XIOR Stream: /tmp/checkit_origin_1
Working dir:        /mnt/origin
Making 1st snapshot of origin volume
Mounting 1st snap volume
Checking files on /mnt/fs_snap1
checkit starting with:
VERIFY
Verify XIOR Stream: /tmp/checkit_origin_1
Working dir:        /mnt/fs_snap1
*** DATA COMPARISON ERROR [file:dxvpxwvnqsjerbwemynqfepxdmsvygnegmvgjstbngh] ***
Corrupt regions follow - unprintable chars are represented as '.'
-----------------------------------------------------------------
corrupt bytes starting at file offset 0
    1st 32 expected bytes:  FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
    1st 32 actual bytes:    EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE

checkit verify failed



[root@hayes-03 tmp]# lvs -a -o +devices
  LV       VG         Attr   LSize  Origin Snap%  Move Log Copy%  Convert Devices              
  LogVol00 VolGroup00 -wi-ao 72.44G                                       /dev/sda2(0)         
  LogVol01 VolGroup00 -wi-ao  1.94G                                       /dev/sda2(2318)      
  fs_snap1 snapper    swi-ao  3.50G origin   0.00                         /dev/etherd/e1.1p2(0)
  origin   snapper    owi-ao  4.00G                                       /dev/etherd/e1.1p1(0)


2.6.18-92.el5

lvm2-2.02.39-2.el5    BUILT: Wed Jul  9 07:26:29 CDT 2008
lvm2-cluster-2.02.39-1.el5    BUILT: Thu Jul  3 09:31:57 CDT 2008
device-mapper-1.02.27-1.el5    BUILT: Thu Jul  3 03:22:29 CDT 2008
Comment 2 RHEL Product and Program Management 2008-09-05 12:43:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 RHEL Product and Program Management 2008-10-27 14:24:13 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 4 Corey Marthaler 2009-01-15 15:50:54 EST
I'm currently unable to reproduce this corruption with the latest 5.3 release. Will close this bug if not seen again in the next couple months...

============================================================
Iteration 607 of 10000 started at Thu Jan 15 14:45:24 CST 2009
============================================================  
SCENARIO - [fs_io_A]                        

2.6.18-128.el5

lvm2-2.02.40-6.el5    BUILT: Fri Oct 24 07:37:33 CDT 2008
lvm2-cluster-2.02.40-7.el5    BUILT: Wed Nov 26 07:19:19 CST 2008
device-mapper-1.02.28-2.el5    BUILT: Fri Sep 19 02:50:32 CDT 2008
cmirror-1.1.36-1.el5    BUILT: Tue Dec  9 16:38:13 CST 2008
kmod-cmirror-0.1.21-10.el5    BUILT: Wed Dec 17 15:18:59 CST 2008
Comment 5 Jonathan Earl Brassow 2009-05-21 09:58:20 EDT
Corey, it has been a few months.  Want to close this?

Eric, I'm wondering if anything related to quiescing an ext3 file system has been fixed in the last 6 months or so?
Comment 6 Eric Sandeen 2009-05-21 11:28:03 EDT
not in rhel5 anyway ...
Comment 7 Corey Marthaler 2009-05-21 12:56:49 EDT
Unable to reproduce this in 5.4. Closing...

Note You need to log in before you can comment on or make changes to this bug.