Bug 46129 - swat does not work
Summary: swat does not work
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-27 00:58 UTC by Bill Shook
Modified: 2007-04-18 16:34 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-06-27 23:06:10 UTC


Attachments (Terms of Use)

Description Bill Shook 2001-06-27 00:58:22 UTC
Description of Problem:
swat connection refused

How Reproducible:
always

Steps to Reproduce:
1. pick swat from the menu---connection refused
2. enter http://127.0.0.1:901-----connection refused
3. 

Actual Results:


Expected Results:


Additional Information:
swat configuration file for 7.1 has changed style and place. It is now
found in /etc/xinetd.d/swat. However, it is wrong! Change the line "server
= /usr/sbin/swat swat" to "server = /usr/sbin/swat". It works then,
assuming "disable = no".

Comment 1 Trond Eivind Glomsrxd 2001-06-27 23:06:05 UTC
It already is that... which version of swat are you running?

Comment 2 Trond Eivind Glomsrxd 2001-06-28 16:09:04 UTC
Version reported against was samba 2.0.8-1.7.1 (no longer current), and I've
verified that this problem is not present in that package.







Comment 3 Need Real Name 2001-07-06 15:29:50 UTC
I use samba 2.0.10 and I modified the /etc/xinetd.d/swat file (I wrote
disable=no), however, as root, swat does not work. The connection is refused. 

Is that normal?

Daniel

Comment 4 Trond Eivind Glomsrxd 2001-07-06 15:37:12 UTC
I'd guess that xinetd either isn't running, or you haven't done a "service
xinetd reload" after the change.


Note You need to log in before you can comment on or make changes to this bug.