Bug 461300 - Client install does not function properly on networks that use AD DNS.
Client install does not function properly on networks that use AD DNS.
Status: CLOSED DUPLICATE of bug 646204
Product: freeIPA
Classification: Community
Component: ipa-client (Show other bugs)
All Linux
medium Severity high
: v2 release
: ---
Assigned To: David O'Brien
Chandrasekar Kannan
: Documentation
Depends On:
Blocks: 431020 489811 646204 646217
  Show dependency treegraph
Reported: 2008-09-05 13:42 EDT by Zak Brown
Modified: 2015-01-04 18:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 646204 (view as bug list)
Last Closed: 2010-11-25 18:03:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Zak Brown 2008-09-05 13:42:51 EDT
The ipa-client-install command is unable to find the IPA server on a network that uses AD DNS.
Comment 1 Brian Likosar 2008-12-23 11:27:10 EST
This is probably due to the fact that AD has its own SRV records for kerberos and ldap that it adds in, so ipa-client-install gets those records instead of any that you might have added for IPA.
Comment 4 Rob Crittenden 2010-09-14 12:33:02 EDT
David, the problem is that we can't know that the SRV records are not for IPA. Please ensure that this it is documented that when running ipa-client-install in an AD environment you may have to manually provide the server to use.
Comment 5 David O'Brien 2010-11-25 18:03:50 EST

*** This bug has been marked as a duplicate of bug 646204 ***

Note You need to log in before you can comment on or make changes to this bug.