Bug 461318 - i810 and intel drivers don't support Intel x4500HD chipset
i810 and intel drivers don't support Intel x4500HD chipset
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 15:15 EDT by Chris Snook
Modified: 2018-04-11 13:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 03:38:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fresh xorg.conf (688 bytes, text/plain)
2008-09-08 19:47 EDT, Chris Snook
no flags Details
i810 xorg.conf (643 bytes, text/plain)
2008-09-08 20:13 EDT, Chris Snook
no flags Details
i810 Xorg.0.log (5.14 KB, text/plain)
2008-09-08 20:14 EDT, Chris Snook
no flags Details
intel Xorg.0.log (11.82 KB, text/plain)
2008-09-08 20:15 EDT, Chris Snook
no flags Details
Xorg log (23.17 KB, text/plain)
2008-09-09 16:56 EDT, Kyle Pablo
no flags Details
intel xorg.conf (634 bytes, text/plain)
2008-09-09 16:58 EDT, Kyle Pablo
no flags Details
xorg log with intel driver (23.49 KB, application/octet-stream)
2008-10-28 15:14 EDT, Brian
no flags Details

  None (edit)
Description Chris Snook 2008-09-05 15:15:06 EDT
Description of problem:
When I try to use the i810 or intel drivers with my shiny new Intel G45 motherboard, they fail to find any screens, forcing me to fall back to vesa and use 1280x1024 on my 1080p display.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.4.2-3.fc10.x86_64
system-config-display-1.0.51-9.fc9.noarch

How reproducible:
100%, on my Intel G45 motherboard

Steps to Reproduce:
1. Install F9 on a box with an Intel G45 chipset
2. (optionally) update to rawhide
3. plug in to a 1920x1080 (1080p) display using either DVI or HDMI
4. run system-config-display

Actual results:
Display is autodetected correctly, driver is set to vesa, and resolution is set to either 1280x1024 (if configuring from scratch) or 800x600 (if recovering from a failed attempt to use i810 or intel).  1920x1080 isn't an option, even after manually setting the display type to 1920x1080 LCD.  If you set the driver to intel or i810, X will fail to find any screens.

Expected results:
intel or i810 driver works, at the native resolution of the display

Additional info:
http://www.intel.com/products/desktop/motherboards/dg45id/dg45id-overview.htm

00:02.0 VGA compatible controller: Intel Corporation Eaglelake Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Intel Corporation Unknown device 5002
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at ff000000 (64-bit, non-prefetchable) [size=4M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at f1c0 [size=8]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
        Capabilities: [d0] Power Management version 2
Comment 1 Matěj Cepl 2008-09-08 15:25:28 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Chris Snook 2008-09-08 19:47:41 EDT
Created attachment 316129 [details]
fresh xorg.conf

Attached is the xorg.conf generated by 'system-config-display --reconfig', and selecting 1280x1024 for the resolution.  s-c-display comes up initially using the vesa driver with resolution at 1280x1024, but with the resolution menu set to 800x600.  1400x1050 is also in the menu, but it does not work.  This is not surprising, since the display has a 1400x1050 mode, but it is only available on the DVI-D port.  The display is connected via HDMI.

The display is capable of 480p, 720p, 1080p, and several VESA modes.  Only the VESA modes work.
Comment 3 Chris Snook 2008-09-08 20:13:47 EDT
Created attachment 316130 [details]
i810 xorg.conf

This is the xorg.conf generated by running 'system-config-display --reconfig' and manually selecting the i810 driver.

The result is identical for the intel driver, except for the string "intel" in place of "i810".  (confirmed by diff)
Comment 4 Chris Snook 2008-09-08 20:14:56 EDT
Created attachment 316131 [details]
i810 Xorg.0.log
Comment 5 Chris Snook 2008-09-08 20:15:48 EDT
Created attachment 316132 [details]
intel Xorg.0.log
Comment 6 Kyle Pablo 2008-09-09 16:56:43 EDT
Created attachment 316254 [details]
Xorg log
Comment 7 Kyle Pablo 2008-09-09 16:57:15 EDT
I am using the Intel X4500HD graphics card with the intel driver.  Attached are my xorg.conf and log file.  I seem to be having problems when I log out.  The screen becomes fuzzy.  Also compiz does not work but thats not a priority.
Comment 8 Kyle Pablo 2008-09-09 16:58:03 EDT
Created attachment 316255 [details]
intel xorg.conf
Comment 9 Chris Snook 2008-09-10 08:58:06 EDT
(In reply to comment #7)
> I am using the Intel X4500HD graphics card with the intel driver.  Attached are
> my xorg.conf and log file.  I seem to be having problems when I log out.  The
> screen becomes fuzzy.  Also compiz does not work but thats not a priority.

I can't use the intel driver at all.  You're hitting a different bug.  Please open a separate BZ for it.
Comment 10 Chris Snook 2008-10-21 04:25:53 EDT
Works fine in F10-snap2.  Feel free to close.
Comment 11 Brian 2008-10-28 15:14:33 EDT
Created attachment 321721 [details]
xorg log with intel driver
Comment 12 Brian 2008-10-28 15:15:00 EDT
I seem to be hitting is bug on f10-snap3 with all the latest updates and the X4500HD.  The vesa driver works but the intel driver just hangs with a black screen and ctrl-alt-bksp doesnt restart X.
Comment 13 Mace Moneta 2008-10-29 01:31:49 EDT
I'm seeing the same as #12. Using a Supermicro C2SEA motherboard with G45 X4500HD.  Everything seemed to work (Compiz, fullscreen video playback), but the system periodically hangs hard or suffers severe screen corruption.I had to switch to NoAccel to stabilize it.
Comment 14 Brian 2008-10-31 08:53:37 EDT
My issue seems to be with using a PAE enabled kernel.  When I use a non PAE kernel on i386 everything worked as expected.  When I installed x86_64 everything worked as expected.
Comment 15 Bug Zapper 2008-11-25 21:58:20 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Rodd Clarkson 2009-02-18 21:19:12 EST
I'm seeing the same thing csnook is seeing, but I'm on a G41 chipset (with integrated into X4500 graphics)

I too am stuck with vesa at 1280x1024.

Ironically, s-c-display offered me 1400x1050 and 1600x1200 (my display is actually 1680x1050) but won't go higher than 1280x1024 anyway.

Do you want log files from me too?
Comment 17 Vedran Miletić 2009-09-06 03:38:48 EDT
Fixed in Fedora 11.

Note You need to log in before you can comment on or make changes to this bug.