Bug 461324 - gvim hangs when GUI is used
gvim hangs when GUI is used
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-05 17:26 EDT by Pete Zaitcev
Modified: 2008-09-08 10:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-08 10:00:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2008-09-05 17:26:10 EDT
Description of problem:

gvim hangs when various GUI elements are used.

Version-Release number of selected component (if applicable):

vim-X11-7.2.006-1.fc10.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Open a document
2. Press "Paste" button in the toolbar
  
Actual results:

Hang

Expected results:

No hang

Additional info:

This is a fresh regression, occured after today's update. HOWEVER, the
/var/log/yum.log says that vim on this system was update on September 02.
So, likely some other component is at fault. But thus far no other
applications were affected.
Comment 1 Pete Zaitcev 2008-09-07 23:06:01 EDT
No change today, still hangs. Oddly enough, gvim changed the theme:
now all the buttons look different. But the gvim itself was not updated.

Karsten, it's a really big issue for me. I cannot work. Going back
to a vi-inside-screen is kinda a big bummer.
Comment 2 Karsten Hopp 2008-09-08 04:17:29 EDT
There is something going on in GNOME, see the 'Strange Gnome Behavior After Rawhide 20080906' thread on fedora-test-list were various packages linked against gnome libs behave very strange. I don't think your problems are caused by something in gvim but in the gnome libs. Did you try to downgrade at least gtk2 and maybe glib2/pango to versions released before that date  ?
Comment 3 Pete Zaitcev 2008-09-08 10:00:23 EDT
It works now, I'm closing the bug.

Definitely not something in vim-X11, but then I have no idea how to
identify the broken component, and gvim was the only applications
doing this for me.

Note You need to log in before you can comment on or make changes to this bug.