Bug 461349 - cmake dies with std::bad_alloc
cmake dies with std::bad_alloc
Status: CLOSED DUPLICATE of bug 453394
Product: Fedora
Classification: Fedora
Component: cmake (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 449510
  Show dependency treegraph
 
Reported: 2008-09-06 05:37 EDT by Andreas Bierfert
Modified: 2008-09-08 10:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-08 10:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Orion Poplawski 2008-09-06 12:52:46 EDT
I've seen these failures on the xenbuilders but not on the x86 hosts.  Possibly an infrastructure issue, possibly cmake using much more memory than it should (or both).  For now, re-submit and hopefully you won't get a xenbuilder.
Comment 2 Andreas Bierfert 2008-09-07 03:22:05 EDT
You seem to be right. If it does not hit a xen builder the job goes through w/o problems.
Comment 3 Rex Dieter 2008-09-08 09:46:12 EDT
Dang, I had seen this too, but had thought that the parens patch would help here, guess not.  :(
Comment 4 Orion Poplawski 2008-09-08 10:24:38 EDT
This is basically caused by popen() not working on xen kernels.

*** This bug has been marked as a duplicate of bug 453394 ***
Comment 5 Orion Poplawski 2008-09-08 10:28:44 EDT
Infrastructure ticket:

https://fedorahosted.org/fedora-infrastructure/ticket/811

Note You need to log in before you can comment on or make changes to this bug.