Bug 461387 - Please document resolv.conf hijacking
Please document resolv.conf hijacking
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-07 00:08 EDT by Tom Horsley
Modified: 2014-03-16 23:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-08 13:27:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2008-09-07 00:08:07 EDT
Description of problem:

Apparently the new network init script (or something it invokes, I'm not sure
exactly who is responsible) is now hijacking the /etc/resolv.conf file
and moving the original to /etc/resolv.conf.save. It apparently does this
even for static IP systems in which every sysadmin everywhere in the universe
just knows that they can edit the /etc/resolv.conf file to change DNS
info.

This is unexpected, unnecessary, and annoying, but if you insist on
keeping it this way, will someone please add a big honking comment to
the generated resolv.conf file explaining where to find the file
that actually needs to be edited to change the DNS info in a permanent
fashion? I'm imagining it may be the ifcfg script for the interface
because I see DNS1 and DNS2 lines in there, but what on earth happens
when there are multiple interfaces?

Version-Release number of selected component (if applicable):
initscripts-8.81-1.x86_64

How reproducible:
every time

Steps to Reproduce:
1. config system with static IP
2. try to change DNS server by editing /etc/resolv.conf
3. reboot, and watch the stale servers reappear.
  
Actual results:
perplexed sysadmin

Expected results:
permanent change to resolv.conf

Additional info:
Comment 1 Bill Nottingham 2008-09-08 13:27:46 EDT
It's always been this way. See DNS1/DNS2 and PEERDNS in /usr/share/doc/initscripts-*/sysconfig.txt.
Comment 2 Tom Horsley 2008-09-08 15:45:11 EDT
It can't possibly have always been this way, because it never happened
till I installed F10, and even if it had always been thus, there is
no excuse for NOT putting a comment in the generated resolv.conf describing
the location of the actual master source for the DNS info so folks
attempting to edit resolv.conf can discover what they should really edit.
Comment 3 D. Wagner 2008-09-13 14:20:15 EDT
Seems like not a bad idea to have a comment in the /etc/resolv.conf pointing to where to go modify (e.g., saying "read /usr/share/doc/initscripts-*/sysconfig.txt to add extra DNS servers instead of editing this file").  I too have struggled with a similar issue and lost some time trying to debug it.

Note You need to log in before you can comment on or make changes to this bug.