Bug 461399 - Pidgin does not accept Bonjour chats - unless conversation window is open
Pidgin does not accept Bonjour chats - unless conversation window is open
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
9
i386 All
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-07 05:58 EDT by Florian Fahr
Modified: 2008-11-20 17:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 17:29:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Fahr 2008-09-07 05:58:40 EDT
Description of problem:
I cannot initiate Bonjour chats over Pidgin. Messages can only be sent if both persons have double-clicked each other in the contact list and thus have a conversation window open for each other. Pidgin seems to be the only client having this problem, others (mainly iChat) don't seem to present this.

Version-Release number of selected component (if applicable):
Pidgin 2.4.3-1.fc9

How reproducible:
Always

Steps to Reproduce:
1. Connect two computers via LAN
2. Create a "Bonjour" account on both in Pidgin (Manage accounts -> Add -> Protocol "Bonjour")
3. The two computers should have found each other automatically already.
4. Select computer B on computer A and open a chat window.
5. Type a message and send it.

Actual results:
The message won't be transmitted.

Expected results:
The message should be transmitted.

Additional info:

Opening a chat window with computer A on computer B as well will enable Pidgin to send messages via Bonjour, however closing one of them will make the messages fail again.
Comment 1 Florian Fahr 2008-09-07 06:22:55 EDT
Forgot to mention: This issue still happens in Pidgin 2.5.1 which I was able to test on a Windows XP machine.
Comment 2 Daniel Atallah 2008-11-20 17:26:08 EST
This is almost certainly caused by a firewall preventing the connection to the remote client in order to start a conversation.

The debug log (Help->Debug Window) output will confirm this.
Comment 3 Warren Togami 2008-11-20 17:45:45 EST
Just for future reference, opening 5298/tcp fixes this problem.

Note You need to log in before you can comment on or make changes to this bug.