Bug 461416 - plymouth ask-for-password --command sends garbage to command
plymouth ask-for-password --command sends garbage to command
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-07 13:43 EDT by Milan Broz
Modified: 2013-02-28 23:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 09:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Broz 2008-09-07 13:43:34 EDT
initcript contain this line (system with encrypted PV)

plymouth ask-for-password --command "cryptsetup luksOpen /dev/sda2 luks-sda2"

Running in text mode, it requires password twice, because first attempt fails (even witout touching keyboard!)

As I found, cryptsetup always receive on standard input 4 chars, no idea where they are from, but these are completely garbage not password.

Just tried to replace crypsetup with simple test program
while (read(0, &c, 1) == 1)
  ...

And I see the same.

Version-Release number of selected component (if applicable):

plymouth-0.6.0-0.2008.08.27.2.fc10.i386
mkinitrd-6.0.62-1.fc10.i386

Plymouth ask-for-password should probably drain the output before asking password again.
Comment 1 Ray Strode [halfline] 2008-09-07 17:07:57 EDT
Are you still seeing this with the latest plymouth?

I did some fixes on friday, including:

* Fri Sep  5 2008 Ray Strode <rstrode@redhat.com> 0.5.0-0.2008.09.05.1
- Fix some confusion with password handling in details plugin


Make sure you rebuild your initrd after updating with

/sbin/mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r)
Comment 2 Milan Broz 2008-09-08 07:57:29 EDT
Seems that it works with 0.6.0-0.2008.09.05.3.f10, but tested on other confuguration.

I'll verify it on my test system later this week.
Comment 3 Ray Strode [halfline] 2008-09-23 14:00:49 EDT
marking MODIFIED waiting verification
Comment 4 Milan Broz 2008-10-06 07:26:44 EDT
Works with F10-beta, thanks.

Note You need to log in before you can comment on or make changes to this bug.