Bug 461417 - Cursor disappears when using vertically split window in gVim
Cursor disappears when using vertically split window in gVim
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-07 13:55 EDT by Ben Gamari
Modified: 2011-11-13 16:55 EST (History)
7 users (show)

See Also:
Fixed In Version: 7.2.148-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 13:57:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Gamari 2008-09-07 13:55:00 EDT
Description of problem:
When one creates a vertical window (Ctrl-W, V) in a gVim session (even in a horizontally split window) the text cursor (caret?) disappears. This behavior is not exhibited with horizontal windows (Ctrl-W, N) nor after all vertical windows have been destroyed.


Version-Release number of selected component (if applicable):


How reproducible:
Always.


Steps to Reproduce:
1. Open gVim
2. Press Ctrl-W, V
  
Actual results:
The cursor is missing.

Expected results:
The cursor is visible and behaves normally.


Additional info:
Comment 1 Ben Gamari 2008-09-16 15:38:03 EDT
What is the status of this? Has anyone else been able to reproduce this. It's really making using vim a pain in the butt.
Comment 2 Ben Gamari 2008-09-18 18:43:54 EDT
I have no idea what happened but gvim seems to have magically fixed itself as of today. Looking back at yum.log, I really don't see anything directly related to gVim changing. With all of the recent xorg (especially intel) changes in rawhide recently, I wouldn't be surprised if this was bug was simply a rendering error.
Comment 3 Ben Gamari 2008-09-19 19:38:05 EDT
Apparently, the problem is not fixed but instead contingent on the window being maximized. Whenever the gVim is in a non-maximized state the cursor works as expected. When maximized, however, it disappears when there is a vertical window.
Comment 4 Christopher D. Stover 2008-10-22 23:14:21 EDT
Hi Ben, I just installed vim-X11-7.2.025-1.fc10.i386 but I can't recreate your problem.  Are you still having trouble?
Comment 5 Ben Gamari 2008-10-23 13:29:48 EDT
Yes, I'm still experiencing the issue intermittently with vim-X11.x86_64-2:7.2.025-1.fc10. Try the following,

- Open gVim
- Maximize the window
- Press Ctrl-W, N
- Press Ctrl-W, V

At this point, you should find that the cursor has disappeared. Unmaximizing and remaximizing the window should restore the cursor.
Comment 6 Christopher D. Stover 2008-10-23 13:42:01 EDT
(In reply to comment #5)
> Yes, I'm still experiencing the issue intermittently with
> vim-X11.x86_64-2:7.2.025-1.fc10. Try the following,
> 
> - Open gVim
> - Maximize the window
> - Press Ctrl-W, N
> - Press Ctrl-W, V
> 
> At this point, you should find that the cursor has disappeared. Unmaximizing
> and remaximizing the window should restore the cursor.

Still no problems for me.  My cursor is fine when I maximize the window.  As soon as I press Ctrl-W my cursor disappears but when I move the mouse it reappears.  The same applies for when I press Ctrl-W, N or V, it comes back as soon as I move the mouse.  Perhaps just a problem in 64-bit?
Comment 7 Tomasz Torcz 2008-10-23 14:41:21 EDT
I can reproduce this bug with maximising window. When window is not maximised, cursors do *not* disappear. Also, cursor do *not* disappear If I manually change window size after starting gvim.

I'm on x86_64.
Comment 8 Bug Zapper 2008-11-25 21:59:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Martin Nagy 2008-11-28 05:57:44 EST
I can reproduce this as well. After googling I also found this: http://bbs.archlinux.org/viewtopic.php?id=58308

vim-X11-7.2.025-2.fc10.x86_64
Comment 10 Ryan McDougall 2009-02-04 06:56:43 EST
I can confirm on  vim-X11-7.2.060-1.fc10.i386

Resizing the window appears to cause the cursor to return.
Comment 11 vaxon 2009-03-09 17:29:39 EDT
I'm also experiencing weird cursor issues with vim-X11-7.2.060-1.fc10.x86_64.
Open any 2 files with gvim -O file1 file2 and the cursor is invisible.
It becomes visible again after the gvim window is resized.
The problem only happens with vertical split. Horizontal split is fine.
Comment 12 vaxon 2009-03-27 07:18:09 EDT
Same problem here with vim-X11-7.2.060-1.fc10.x86_64.
If I open a terminal window in gnome and maximize it and then do gvim -O a b, gvim opens with invisible cursor. If I keep the teminal window small enough, gvim also opens in a smaller window and cursor is visible then. It's kind of weird.

To make cursor visible I have to resize the gvim window. It's really annoying, since I have a 19020x1200 resolution and use vertical split a lot.

Thanks,
Vax.
Comment 13 Fedora Update System 2009-03-27 08:50:52 EDT
vim-7.2.148-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/vim-7.2.148-1.fc10
Comment 14 Fedora Update System 2009-03-31 16:36:08 EDT
vim-7.2.148-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update vim'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3169
Comment 15 Fedora Update System 2009-04-15 13:57:44 EDT
vim-7.2.148-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Joel 2010-06-29 14:43:21 EDT
This bug is still happening on Fedora 12
Comment 17 Juan J. Martínez 2011-11-13 16:51:03 EST
This bug is now happening in Fedora 16.

$ rpm -qa | grep vim
vim-X11-7.3.315-1.fc16.i686
vim-minimal-7.3.315-1.fc16.i686
vim-filesystem-7.3.315-1.fc16.i686
vim-enhanced-7.3.315-1.fc16.i686
vim-common-7.3.315-1.fc16.i686
Comment 18 Juan J. Martínez 2011-11-13 16:55:50 EST
I can reproduce the bug with the steps pointed at: https://bugzilla.redhat.com/show_bug.cgi?id=461417#c5

- Open gVim
- Maximize the window
- Press Ctrl-W, N
- Press Ctrl-W, V

At this point, you should find that the cursor has disappeared. Unmaximizing
and remaximizing the window should restore the cursor.

Note You need to log in before you can comment on or make changes to this bug.