Bug 461420 - pptp fails to establish a connection
pptp fails to establish a connection
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager-pptp (Show other bugs)
11
All Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-09-07 15:21 EDT by Arthur Pemberton
Modified: 2009-11-23 20:42 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-23 20:42:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of failures (11.58 KB, text/plain)
2008-09-07 15:21 EDT, Arthur Pemberton
no flags Details
log of failure with NetworkManager-pptp and success with pptpconfig (20.84 KB, text/plain)
2008-11-06 11:02 EST, Arthur Pemberton
no flags Details
failed VPN connection, /var/log/messages (2.06 KB, text/plain)
2009-11-07 18:30 EST, Arthur Pemberton
no flags Details

  None (edit)
Description Arthur Pemberton 2008-09-07 15:21:12 EDT
Created attachment 315972 [details]
log of failures

Description of problem:

The plugin fails to establish a connection that is known to be working. I can successfully establish a connection with pptp-config

Version-Release number of selected component (if applicable):
0.7.0-0.10.svn4027.fc10.i386


How reproducible:
Every time


Steps to Reproduce:
1. Setup VPN with NetworkManager
2. Attempt to establish VPN


Actual results:
Connection fails


Expected results:
Connection is established, routes are added


Additional info:

pacakges of possible relevance:
NetworkManager-pptp-0.7.0-0.10.svn4027.fc10.i386
pptp-1.7.2-3.fc10.i386
pptp-release-4-2.fc9.noarch
pptpconfig-20060821-1.fc9.noarch

everything should be up-to-date as of rawhide 2008-09-06.

I have attached seemingly relevant portions of /var/log/messages showing:
18:13 - I tried to connect using NetworkManager and failed
18:18 - I tried pptp-client and succeeded
18:29 - I tried NetworkManager again, this time with MPPE on (which
I had forgotten the first time) and failed


Mailing list threads which precede this:

https://www.redhat.com/archives/fedora-devel-list/2008-August/msg01419.html
https://www.redhat.com/archives/fedora-devel-list/2008-September/msg00007.html
Comment 1 Arthur Pemberton 2008-09-07 15:22:40 EDT
I have not yet verified if kNetworkManager-pptp works or not mostly as I am uncertain as to how I would switch between the two applets.
Comment 2 Bill Nottingham 2008-11-05 16:49:58 EST
Please test with the latest rawhide NetworkManager-pptp - bugs were fixed in this area.
Comment 3 Arthur Pemberton 2008-11-06 11:02:11 EST
Created attachment 322746 [details]
log of failure with NetworkManager-pptp and success with pptpconfig

On fully updated (as of 7 hours prior to this posting) rawhide machine, all attempt to connect to pptp VPN via NetworkManager-ptp-0.7.0-0.12.svn4229.fc10.i386

Slightly sanitized and annotated /var/log/messages attached (messages-200811060346.log)
Comment 4 slamp 2008-11-16 14:04:47 EST
download the latest pptp from http://sourceforge.net/project/showfiles.php?group_id=33063&package_id=25151&release_id=599125 and it seems to work. i had the same issue as you. the version included (1.7.1) in fedora does not seem to work with networkmanager.1.7.2 works wonders.
Comment 5 Bug Zapper 2008-11-25 21:59:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Adam Sobotka 2008-12-24 06:43:33 EST
still unresolved?
Dec 24 12:41:09 localhost kernel: CE: hpet increasing min_delta_ns to 15000 nsec
Dec 24 12:41:29 localhost NetworkManager: <info>  Starting VPN service 'org.freedesktop.NetworkManager.pptp'...
Dec 24 12:41:29 localhost NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.pptp' started (org.freedesktop.NetworkManager.pptp), PID 5115
Dec 24 12:41:29 localhost NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.pptp' just appeared, activating connections
Dec 24 12:41:29 localhost NetworkManager: <info>  VPN plugin state changed: 3
Dec 24 12:41:29 localhost NetworkManager: <info>  VPN connection 'VPN connection 1' (Connect) reply received.
Dec 24 12:41:30 localhost pppd[5118]: Plugin /usr/lib/pppd/2.4.4/nm-pptp-pppd-plugin.so loaded.
Dec 24 12:41:30 localhost pppd[5118]: pppd 2.4.4 started by root, uid 0
Dec 24 12:41:30 localhost pppd[5118]: Using interface ppp0
Dec 24 12:41:30 localhost pppd[5118]: Connect: ppp0 <--> /dev/pts/0
Dec 24 12:41:30 localhost pptp[5119]: nm-pptp-service-5115 log[main:pptp.c:314]: The synchronous pptp option is NOT activated
Dec 24 12:41:30 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 1 'Start-Control-Connection-Request'
Dec 24 12:41:30 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_disp:pptp_ctrl.c:739]: Received Start Control Connection Reply
Dec 24 12:41:30 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_disp:pptp_ctrl.c:773]: Client connection established.
Dec 24 12:41:31 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 7 'Outgoing-Call-Request'
Dec 24 12:41:31 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_disp:pptp_ctrl.c:858]: Received Outgoing Call Reply.
Dec 24 12:41:31 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_disp:pptp_ctrl.c:897]: Outgoing call established (call ID 0, peer's call ID 59565).
Dec 24 12:41:31 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_disp:pptp_ctrl.c:950]: PPTP_SET_LINK_INFO received from peer_callid 0
Dec 24 12:41:31 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_disp:pptp_ctrl.c:953]:   send_accm is 00000000, recv_accm is FFFFFFFF
Dec 24 12:41:31 localhost pptp[5128]: nm-pptp-service-5115 warn[ctrlp_disp:pptp_ctrl.c:956]: Non-zero Async Control Character Maps are not supported!
Dec 24 12:41:31 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_disp:pptp_ctrl.c:950]: PPTP_SET_LINK_INFO received from peer_callid 0
Dec 24 12:41:31 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_disp:pptp_ctrl.c:953]:   send_accm is FFFFFFFF, recv_accm is FFFFFFFF
Dec 24 12:41:31 localhost pptp[5128]: nm-pptp-service-5115 warn[ctrlp_disp:pptp_ctrl.c:956]: Non-zero Async Control Character Maps are not supported!
Dec 24 12:41:31 localhost pppd[5118]: LCP terminated by peer (qM-^UxP^@<M-Mt^@^@^BM-3)
Dec 24 12:41:31 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_disp:pptp_ctrl.c:912]: Received Call Clear Request.
Dec 24 12:41:34 localhost pppd[5118]: Connection terminated.
Dec 24 12:41:34 localhost NetworkManager: <info>  VPN plugin failed: 1
Dec 24 12:41:34 localhost pptp[5119]: nm-pptp-service-5115 warn[decaps_hdlc:pptp_gre.c:204]: short read (-1): Input/output error
Dec 24 12:41:34 localhost pptp[5119]: nm-pptp-service-5115 warn[decaps_hdlc:pptp_gre.c:216]: pppd may have shutdown, see pppd log
Dec 24 12:41:34 localhost pptp[5128]: nm-pptp-service-5115 log[callmgr_main:pptp_callmgr.c:234]: Closing connection (unhandled)
Dec 24 12:41:34 localhost pptp[5128]: nm-pptp-service-5115 log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 12 'Call-Clear-Request'
Dec 24 12:41:34 localhost pptp[5128]: nm-pptp-service-5115 log[call_callback:pptp_callmgr.c:79]: Closing connection (call state)
Dec 24 12:41:34 localhost pppd[5118]: Modem hangup
Dec 24 12:41:34 localhost pppd[5118]: Exit.
Dec 24 12:41:34 localhost NetworkManager: <info>  VPN plugin failed: 1
Dec 24 12:41:34 localhost NetworkManager: <info>  VPN plugin failed: 1
Dec 24 12:41:34 localhost NetworkManager: <info>  VPN plugin state changed: 6
Dec 24 12:41:34 localhost NetworkManager: <info>  VPN plugin state change reason: 0
Comment 7 Adam Sobotka 2008-12-24 08:44:42 EST
and on other side (MS ISA, RADIUS log) it looks like pptp tries to authenticate by computer login:

nm-pptp:
10.253.27.20,adamsobotka-pc,12/24/2008,14:25:07,IAS,WNTP5,12,1500,44,51631,4,10.253.27.20,6,2,7,1,5,102,61,5,64,1,65,1,31,212.24.157.233,66,212.24.157.233,4108,10.253.27.20,4116,311,4128,ISA,4147,311,4148,MSRASV5.20,4155,1,4154,Use Windows authentication for all users,25,311 1 10.253.27.28 12/06/2008 20:22:27 14486,4129,GLOBUS\adamsobotka-pc,4130,GLOBUS\adamsobotka-pc,4127,5,4136,1,4142,0
10.253.27.20,adamsobotka-pc,12/24/2008,14:25:07,IAS,WNTP5,25,311 1 10.253.27.28 12/06/2008 20:22:27 14486,4127,5,4130,GLOBUS\adamsobotka-pc,4129,GLOBUS\adamsobotka-pc,4154,Use Windows authentication for all users,4155,1,4128,ISA,4116,311,4108,10.253.27.20,4136,3,4142,8

windows client:
10.253.27.20,GLOBUS\sobotka,12/24/2008,14:26:49,IAS,WNTP5,44,51632,4,10.253.27.20,6,2,7,1,5,102,61,5,64,1,65,1,31,212.24.157.233,66,212.24.157.233,4108,10.253.27.20,4116,311,4128,ISA,4147,311,4148,MSRASV5.20,4160,MSRASV5.20,4159,MSRAS-0-ADAMSOBOTKA-NB,4155,1,4154,Use Windows authentication for all users,4129,GLOBUS\sobotka,4127,4,25,311 1 10.253.27.28 12/06/2008 20:22:27 14487,4130,globus.cz/Globus/Centrala/Users/Sobotka Adam,4149,VPN Users,4136,1,4142,0
10.253.27.20,GLOBUS\sobotka,12/24/2008,14:26:49,IAS,WNTP5,25,311 1 10.253.27.28 12/06/2008 20:22:27 14487,4130,globus.cz/Globus/Centrala/Users/Sobotka Adam,4294967206,4,4294967207,2,6,2,7,1,4149,VPN Users,4120,0x00474C4F425553,4108,10.253.27.20,4116,311,4128,ISA,4127,4,4129,GLOBUS\sobotka,4154,Use Windows authentication for all users,4155,1,4136,2,4142,0

Or..is my bug just another bug in nm-pptp?
Comment 8 Arthur Pemberton 2009-04-04 14:42:40 EDT
A few things now that I am on F10.

1) the PPTP plugin works (for me)
2) if I enter a route and tell it to only use my routes, the connection dies in less than 5 minutes and never actually works (it could be me not adding my route properly but I was able to figure it otu for pptp-config)
3) I am select EAP and connection dies and makes no suggestions even if viewing the log makes EAP the most likely candidate
4) The applet doesn't really give a notification when the VPN becomes active
5) Is there any consideration towards giving NM its own /var/log file PPPD seems to throw quite a bit of syslog output, which I don't mind, just that I may want to find something else in that log easily.

My only priority is the routes as this particular VPN connection will only route HTTP directed outside its network, so all my other connections die. Plus I don't want to send all my traffic through the VPN.
Comment 9 Arthur Pemberton 2009-06-22 00:12:21 EDT
Should I close this?
Comment 10 Arthur Pemberton 2009-11-07 18:30:08 EST
Created attachment 367981 [details]
failed VPN connection, /var/log/messages

NetworkManager-pptp worked for awhile and then stopped again
Comment 11 Arthur Pemberton 2009-11-23 20:42:09 EST
Works for me as of today.

Note You need to log in before you can comment on or make changes to this bug.