Bug 461458 - kernel returns EPERM when RLIMIT_NOFILE is set to RLIM_INFINITY
kernel returns EPERM when RLIMIT_NOFILE is set to RLIM_INFINITY
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 461913 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-08 04:33 EDT by Adam Tkac
Modified: 2013-04-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-04 05:52:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
testcase (836 bytes, text/plain)
2008-09-08 04:33 EDT, Adam Tkac
no flags Details
proposed patch (908 bytes, patch)
2008-09-08 04:37 EDT, Adam Tkac
no flags Details | Diff

  None (edit)
Description Adam Tkac 2008-09-08 04:33:59 EDT
Created attachment 316052 [details]
testcase

Description of problem:
when I want set open files limit to infinity kernel returns EPERM.

Version-Release number of selected component (if applicable):
$ uname -r
2.6.27-0.312.rc5.git7.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
try run attached testcase (under root, of course) and see output from strace
  
Actual results:
limit is not set, EPERM is returned

Expected results:
limit is set to "infinity" (currently NR_OPEN)
Comment 1 Adam Tkac 2008-09-08 04:37:12 EDT
Created attachment 316057 [details]
proposed patch
Comment 2 Dave Jones 2008-09-08 14:33:17 EDT
If you haven't already, can you send this to linux-kernel@vger.kernel.org please ?

Thanks.
Comment 3 Adam Tkac 2008-09-11 13:13:11 EDT
(In reply to comment #2)
> If you haven't already, can you send this to linux-kernel@vger.kernel.org
> please ?
> 
> Thanks.

Done, already in MM tree. Would it be possible include attached patch to next distribution kernel update, please? (all F8/F9/rawhide kernels) It is needed by bind package (bug #461913). Thanks
Comment 4 Adam Tkac 2008-09-15 08:18:59 EDT
Improved version of patch is on http://lkml.org/lkml/2008/9/12/56
Comment 5 Adam Tkac 2008-09-22 09:14:53 EDT
*** Bug 461913 has been marked as a duplicate of this bug. ***
Comment 6 Brennan Ashton 2008-11-04 00:34:31 EST
Has this patch made it into the kernel, if so please close this bug.
Comment 7 Adam Tkac 2008-11-04 05:52:02 EST
Patch has been merged in 0c2d64fb6cae9aae480f6a46cfe79f8d7d48b59f (2.6.28 series), closing

Note You need to log in before you can comment on or make changes to this bug.