Bug 461541 - mkisofs: Unexpected joliet directory length
mkisofs: Unexpected joliet directory length
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cdrtools (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Harald Hoyer
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-08 18:37 EDT by Mike Bonnet
Modified: 2014-06-11 07:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 11:21:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (2.79 KB, patch)
2008-09-16 13:56 EDT, Harald Hoyer
no flags Details | Diff

  None (edit)
Description Mike Bonnet 2008-09-08 18:37:17 EDT
Description of problem:
Sometimes when running mkisofs on RHEL-5, mkisofs will output a warning like this:

mkisofs: Unexpected joliet directory length 530 expected: 534 ''

and the resulting .iso will have invalid Joliet information, and be unreadable on Windows.  In this case 

Version-Release number of selected component (if applicable):
mkisofs-9:2.01-10.6.el5

How reproducible:
sporadically

Steps to Reproduce:
1. use mkisofs to create an iso image with Joliet headers
2. examine the resulting iso
3.
  
Actual results:
$ isoinfo -l -J -i bad.iso

Directory listing of /
d---------   0    0    0            2048 Sep  8 2008 [     39 02]  . 
----------   0    0    0            2048 Dec 31 1969 [     28 00]  .. 
----------   0    0    0       687865856      8 1900 [4063278 0D]  . 
----------   0    0    0         7602286     54 2016 [6226030 00]   

Expected results:
$ isoinfo -l -J -i good.iso

Directory listing of /
d---------   0    0    0            2048 Sep  8 2008 [     39 02]  . 
d---------   0    0    0            2048 Sep  8 2008 [     39 02]  .. 
d---------   0    0    0            2048 Aug 19 2008 [     41 02]  Common_Content 
----------   0    0    0            8995 Aug 19 2008 [     91 00]  README.txt 
...more...

Additional info:

The Rock Ridge information also contains the weird .. entry (with a date in 1969) but it is able to display the entire contents of the image.

This appears to be the same problem as:

https://bugs.launchpad.net/ubuntu/+source/cdrkit/+bug/187459
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=429244
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=430558
Comment 5 Mike Bonnet 2008-09-16 13:50:49 EDT
That package looks like it fixes it for me.  Excellent!

$ ls -laU iso-test
total 20
-rw-rw-r-- 1 root root    0 Sep  9 11:29 test.txt
drwxrwxrwt 4 root root 4096 Sep 16 13:45 ..
drwxrwxr-x 2 root root 4096 Sep  9 11:29 .

$ mkisofs -v -v -o test-newmkisofs.iso -r -J iso-test
INFO:	UTF-8 character encoding detected by locale settings.
	Assuming UTF-8 encoded filenames on source filesystem,
	use -input-charset to override.
mkisofs 2.01 (cpu-pc-linux-gnu)
Scanning iso-test
  28   362 
Cache hit for '/..'
Writing:   Initial Padblock                        Start Block 0
Done with: Initial Padblock                        Block(s)    16
Writing:   Primary Volume Descriptor               Start Block 16
Done with: Primary Volume Descriptor               Block(s)    1
Writing:   Joliet Volume Descriptor                Start Block 17
Done with: Joliet Volume Descriptor                Block(s)    1
Writing:   End Volume Descriptor                   Start Block 18
Done with: End Volume Descriptor                   Block(s)    1
Writing:   Version block                           Start Block 19
Done with: Version block                           Block(s)    1
Writing:   Path table                              Start Block 20
Done with: Path table                              Block(s)    4
Writing:   Joliet path table                       Start Block 24
Done with: Joliet path table                       Block(s)    4
Writing:   Directory tree                          Start Block 28
Done with: Directory tree                          Block(s)    1
Writing:   Joliet directory tree                   Start Block 29
Done with: Joliet directory tree                   Block(s)    1
Writing:   Directory tree cleanup                  Start Block 30
Done with: Directory tree cleanup                  Block(s)    0
Writing:   Extension record                        Start Block 30
Done with: Extension record                        Block(s)    1
Writing:   The File(s)                             Start Block 31
Total extents scheduled to be written = 181
Total translation table size: 0
Total rockridge attributes bytes: 249
Total directory bytes: 0
Path table size(bytes): 10
Done with: The File(s)                             Block(s)    0
Writing:   Ending Padblock                         Start Block 31
Done with: Ending Padblock                         Block(s)    150
Max brk space used 0
181 extents written (0 MB)

$ isoinfo -l -J -i test-newmkisofs.iso

Directory listing of /
d---------   0    0    0            2048 Sep  9 2008 [     29 02]  . 
d---------   0    0    0            2048 Sep  9 2008 [     29 02]  .. 
----------   0    0    0               0 Sep  9 2008 [     31 00]  test.txt 

$ isoinfo -l -R -i test-newmkisofs.iso

Directory listing of /
dr-xr-xr-x   2    0    0            2048 Sep  9 2008 [     28 02]  . 
dr-xr-xr-x   2    0    0            2048 Sep  9 2008 [     28 02]  .. 
-r--r--r--   1    0    0               0 Sep  9 2008 [     31 00]  test.txt
Comment 6 Harald Hoyer 2008-09-16 13:56:14 EDT
Created attachment 316869 [details]
proposed patch
Comment 7 RHEL Product and Program Management 2008-09-16 14:12:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 20 Michal Nowak 2008-10-07 09:35:05 EDT
/CoreOS/cdrtools/Sanity/mkisofs/461541-mkisofs-Unexpected-joliet-directory-length
Comment 22 errata-xmlrpc 2008-10-15 11:21:41 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0574.html
Comment 23 Jörg Schilling 2014-06-11 07:06:31 EDT
The text in 

http://rhn.redhat.com/errata/RHBA-2008-0574.html

claims that RedHat did upgrade cdrtools, but this is not true.
RedHat still ships the defective dead fork from 10 years ago.

If you like to get fixes for the various documented bugs, upgrade
to reent original code from:

https://sourceforge.net/projects/cdrtools/files/alpha/
or
https://sourceforge.net/projects/cdrtools/files/

Note You need to log in before you can comment on or make changes to this bug.