Bug 461545 - (ati-modesetting) Kernel Modesetting fails on Ati xpress 1100 pci card.
Kernel Modesetting fails on Ati xpress 1100 pci card.
Status: CLOSED DUPLICATE of bug 464896
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-08 20:17 EDT by Joshua Covington
Modified: 2008-10-31 20:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 20:56:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg from the kernel with nomodeset, otherwise no screen is available (46.96 KB, application/octet-stream)
2008-09-08 20:17 EDT, Joshua Covington
no flags Details
Xorg.0.log, fc9, kernel-2.6.26.3-29 (37.81 KB, application/octet-stream)
2008-09-08 20:21 EDT, Joshua Covington
no flags Details
Xorg.0.log with kernel-2.6.27-0.314.rc5.git9.fc10.i686 nomodeset (38.46 KB, application/octet-stream)
2008-09-08 20:40 EDT, Joshua Covington
no flags Details
dmesg-2.6.27-0.317.rc5.git10.fc10.i686 (47.15 KB, application/octet-stream)
2008-09-09 15:43 EDT, Joshua Covington
no flags Details
Xorg.0.log-2.6.27-0.317.rc5.git10.fc10.i686 (37.83 KB, application/octet-stream)
2008-09-09 15:44 EDT, Joshua Covington
no flags Details
dmesg-2.6.27-0.322.rc6.fc10.i686 nomodeset (47.11 KB, application/octet-stream)
2008-09-10 18:39 EDT, Joshua Covington
no flags Details
Xorg.0.log-2.6.27-0.322.rc6.fc10.i686 (37.82 KB, application/octet-stream)
2008-09-10 18:40 EDT, Joshua Covington
no flags Details
dmesg-2.6.27.0-322.rc6.fc10.i686 nomodeset 3 (57.81 KB, application/octet-stream)
2008-09-11 09:45 EDT, Joshua Covington
no flags Details
Xorg.0.log after modprobe drm debug=1 (38.18 KB, application/octet-stream)
2008-09-11 09:48 EDT, Joshua Covington
no flags Details
dmesg-2.6.27-0.332.rc6.git5.fc10.i686 nomodeset (49.15 KB, application/octet-stream)
2008-09-18 04:32 EDT, Joshua Covington
no flags Details
Xorg.0.log-2.6.27-0.332.rc6.git5.fc10.i686 nomodeset (37.33 KB, application/octet-stream)
2008-09-18 04:34 EDT, Joshua Covington
no flags Details
drm.strace-2.6.27-0.336.rc6.git5.fc10 (13.71 KB, application/octet-stream)
2008-09-19 13:52 EDT, Joshua Covington
no flags Details
dmesg-2.6.27-17.fc10.i686 (40.58 KB, application/octet-stream)
2008-10-16 09:11 EDT, Joshua Covington
no flags Details
Xorg.0.log-2.6.27-17.fc10.i686 (36.70 KB, application/octet-stream)
2008-10-16 09:12 EDT, Joshua Covington
no flags Details

  None (edit)
Description Joshua Covington 2008-09-08 20:17:24 EDT
Created attachment 316134 [details]
dmesg from the kernel with nomodeset, otherwise no screen is available

Description of problem:
The kernel modesetting doesn't work for my ATi xpress 1100 with kernel 2.6.27-0.x. If I pass nomodeset at the command line then everything is fine. Otherwise I got black and white stripps  after starting udev.
I know there is experimental kernel modesetting for the ati cards and therefore decided to file this bug report.
Here is the info for my ati card:
#lspci -vvv
01:05.0 VGA compatible controller: ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP] (prog-if 00 [VGA controller])
        Subsystem: Acer Incorporated [ALI] Unknown device 010f                                                      
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-       
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-      
        Latency: 66 (2000ns min), Cache Line Size: 32 bytes                                                         
        Interrupt: pin A routed to IRQ 17                                                                           
        Region 0: Memory at c8000000 (32-bit, prefetchable) [size=128M]                                             
        Region 1: I/O ports at 9000 [size=256]                                                                      
        Region 2: Memory at c0100000 (32-bit, non-prefetchable) [size=64K]                                          
        [virtual] Expansion ROM at c0120000 [disabled] [size=128K]                                                  
        Capabilities: [50] Power Management version 2                                                               
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)                          
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-                                                         
        Kernel modules: radeonfb    


#lspci -nnn
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS485 [Radeon Xpress 1100 IGP] [1002:5975]


Version-Release number of selected component (if applicable):
kernel-2.6.27-0.314.rc5.git9.fc10.i686 and earlier


How reproducible:
install the kernel with integrated pci ATi xpress 1100 card

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
make it work

Additional info:
Comment 1 Joshua Covington 2008-09-08 20:21:58 EDT
Created attachment 316135 [details]
Xorg.0.log, fc9, kernel-2.6.26.3-29
Comment 2 Joshua Covington 2008-09-08 20:40:11 EDT
Created attachment 316136 [details]
Xorg.0.log with kernel-2.6.27-0.314.rc5.git9.fc10.i686 nomodeset

At the end of the log file there is something w about DRM. Maybe this is the problem.
Comment 3 Joshua Covington 2008-09-09 15:43:16 EDT
Created attachment 316248 [details]
dmesg-2.6.27-0.317.rc5.git10.fc10.i686

still can't work with kernel-2.6.27-0.317.rc5.git10.fc10.i686. I've got the same results like the eralier versions.
Comment 4 Joshua Covington 2008-09-09 15:44:07 EDT
Created attachment 316249 [details]
Xorg.0.log-2.6.27-0.317.rc5.git10.fc10.i686
Comment 5 Joshua Covington 2008-09-10 18:39:10 EDT
Created attachment 316366 [details]
dmesg-2.6.27-0.322.rc6.fc10.i686 nomodeset

Still cannot work with 2.6.27-0.322.rc6.fc10.i686. Nomodeset helps. How can I help with debugging this on my card?
Comment 6 Joshua Covington 2008-09-10 18:40:06 EDT
Created attachment 316367 [details]
Xorg.0.log-2.6.27-0.322.rc6.fc10.i686
Comment 7 Joshua Covington 2008-09-11 09:45:26 EDT
Created attachment 316440 [details]
dmesg-2.6.27.0-322.rc6.fc10.i686 nomodeset 3

 This is what I got after nomodeset 3.
Comment 8 Joshua Covington 2008-09-11 09:48:14 EDT
Created attachment 316441 [details]
Xorg.0.log after modprobe drm debug=1

After modprobe radeon modeset=1 everything freezes and there is no output in the Xorg.0.log about it.
Comment 9 Joshua Covington 2008-09-18 04:32:33 EDT
Created attachment 317046 [details]
dmesg-2.6.27-0.332.rc6.git5.fc10.i686 nomodeset

Still cannot work with 2.6.27-0.332.rc6.git5.fc10.i686. dmesg and Xorg.0.log attached. the kernel was started with nomodeset.
Comment 10 Joshua Covington 2008-09-18 04:34:22 EDT
Created attachment 317047 [details]
Xorg.0.log-2.6.27-0.332.rc6.git5.fc10.i686 nomodeset

nomodeset applied.
Comment 11 Joshua Covington 2008-09-19 13:52:55 EDT
Created attachment 317223 [details]
drm.strace-2.6.27-0.336.rc6.git5.fc10

I tried the new kernel-2.6.27-0.336.rc6.git5.fc10 and the problem still exists. However i hooked strace to modprobe drm debug=1 and this is the result. I tried the same with modprobe radeon modeset=1 but I got no output in the file. How can I do this in order to get the output from loading the driver?
Comment 12 Joshua Covington 2008-09-21 18:47:43 EDT
kernel-2.6.27-0.337.rc6.git5.fc10.i686 doesn't work form me.
Comment 13 Joshua Covington 2008-09-24 12:38:07 EDT
kernel-2.6.27-0.352.rc7.git1.fc10.i686 cannot work either.
Comment 14 Joshua Covington 2008-10-05 10:50:12 EDT
kernel-2.6.27-0.391.rc8.git7.fc10.i686 doesn't work either.
Comment 15 Artem 2008-10-07 14:56:30 EDT
Approved, the same for my Ati XPRESS 1100 card. Problem is more serious, as I can't neither install F10beta nor boot LiveCD without nomodeset option
Comment 16 Joshua Covington 2008-10-08 12:16:10 EDT
kernel-2.6.27-0.398.rc9.fc10.i686 doesn't work either.
Comment 17 Joshua Covington 2008-10-14 17:56:07 EDT
kernel-2.6.27-3.fc10.i686 doesn't work. The same problem still occurs. Only nomodeset can help for now.
Comment 18 Joshua Covington 2008-10-16 09:10:02 EDT
It is working :)
I tried kernel-2.6.27-17.fc10.i686 and i got it this time. There are no hw acceleration for now but I'm sure it'll come. I've attached dmesg and Xorg.0.log for this. They say dri isn't supported for this display and something about EXA not working properly.

Many thanx to all who worked on this and especially to Dave Airlie for fixing this.
Comment 19 Joshua Covington 2008-10-16 09:11:30 EDT
Created attachment 320554 [details]
dmesg-2.6.27-17.fc10.i686
Comment 20 Joshua Covington 2008-10-16 09:12:46 EDT
Created attachment 320555 [details]
Xorg.0.log-2.6.27-17.fc10.i686

At the end of it are EXA errors and dri not working.
Comment 21 Christopher D. Stover 2008-10-22 16:20:07 EDT
Hi Joshua, I'm not sure what your last two posted attachments were for.  Is your problem solved with the new kernels or are you still experiencing issues?  If you're still having issues, I'm going to close this one and mark it as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=464896.
Comment 22 Joshua Covington 2008-10-31 19:10:06 EDT
Hi, yes 2.6.27-17.fc10.i686 resolves the issue. I have modesetting working on my express 1100. I posted the last two attachments just for information and comparison to the others. the xorg.0.log still has some error messages but I'm sure they wil be corrected in the future.
you can mark this as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=464896.
Comment 23 Christopher D. Stover 2008-10-31 20:56:12 EDT
I'm happy to hear your issue was resolved and thank you for your response.

*** This bug has been marked as a duplicate of bug 464896 ***

Note You need to log in before you can comment on or make changes to this bug.