Bug 461549 - Install from USB disk: Awkward to provide a ks.cfg
Install from USB disk: Awkward to provide a ks.cfg
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-08 21:02 EDT by Martin Langhoff
Modified: 2008-09-15 11:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-15 11:56:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Langhoff 2008-09-08 21:02:04 EDT
Description of problem:

When booting anaconda from USB disk

 - a ks.cfg file at the root of the USB disk is not picked up

 - a ks.cfg file at the root of the ISO disk where stage2 is (see #461548) is also ignored

 - the usb disk does not have a stable device - a menu entry in syslinux.cfg setting ks=hd:sdb1:ks.cfg will work _most_ of the time, but is by no means something you can count on...

Version-Release number of selected component (if applicable):

anaconda-11.4.0.82-1.i386
anaconda-runtime-11.4.0.82-1.i386
Comment 1 Jerry Vonau 2008-09-09 12:32:20 EDT
got the logs?
Comment 2 Chris Lumens 2008-09-09 13:09:21 EDT
anaconda never implicitly looks for a kickstart file, so you will always have to tell it that you want to use kickstart and where the file is located.  In rawhide (and hence F10) you are able to say ks=hd:LABEL=whatever:ks.cfg or ks=hd:UUID=whatever:ks.cfg, provided you have given the filesystem a label or UUID.

Does that take care of this problem for you?
Comment 3 Martin Langhoff 2008-09-10 01:50:25 EDT
Chris - you are right, it is correct that the ks file is not picked up automatically.

The problem remains with USB-based installs that there is no way to tell anaconda "use the usb disk you've booted from". For example, "cdrom:" is clearly an alias for "whatever it is - SATA/PATA/USB/SCSI that is the first CD-ROM-like thing in the system".

So to reword my request: can we have a have similar alias, that allows us to say ks=usbdisk:/ks.cfg and have 'usbdisk' mapped to the first usb drive around?

In a separate discussion, Jerry was suggesting a udev rule could help. Perhaps that's how cdrom is implemented?
Comment 4 Jeremy Katz 2008-09-10 09:02:03 EDT
The problem is that different people have a different interpretation of what a "usbdisk" entails.  Is a USB flash drive a disk or just a hard disk?  What about a USB floppy drive?  cdrom: harkens back to the dya when one CD drive was all you (almost) ever had on the system.


More explicit use of mounting by label/uuid for finding things like kickstart configs is definitely the way of the future.

Note You need to log in before you can comment on or make changes to this bug.