Bug 461563 - Winkey/Mod4 does not work often after login to awesome WM
Winkey/Mod4 does not work often after login to awesome WM
Status: CLOSED DUPLICATE of bug 239409
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 03:13 EDT by Michal Nowak
Modified: 2013-03-07 21:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 04:36:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg*log (38.49 KB, text/plain)
2008-09-09 03:13 EDT, Michal Nowak
no flags Details
Mod4 key does not work, #1 (566 bytes, text/plain)
2008-09-09 03:14 EDT, Michal Nowak
no flags Details
Mod4 key does not work, #2 (560 bytes, text/plain)
2008-09-09 03:14 EDT, Michal Nowak
no flags Details
Mod4 key works (561 bytes, text/plain)
2008-09-09 03:15 EDT, Michal Nowak
no flags Details

  None (edit)
Description Michal Nowak 2008-09-09 03:13:12 EDT
Created attachment 316147 [details]
Xorg*log

Description of problem:

I am preparing package for awesome window manager, see bug 452427. It happened in lot of times that after startup of awesome the winkey/mod4 key does not work. It is very annoying because it's the primary functional key.

I am attaching three files, they are outputs from xev (just the winkey/mod4 key press and release). winkey.bad and winkey.bad2 are outputs from xev in awesome when the winkey does not worked and winkey.good when it worked OK. Running vimdiff on all three seems to be interesting in two points.

1) "KeyPress event, serial 2X"
is 25 in good, and 22 or 25 on bad case

2) "KeyRelease event -> state 0x40"
In both bad cases it's "state 0x0" and in good one it's "state 0x40"

It's not happening in GNOME, but I guess the problem is more on Xserver side then on the one of awesome.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.4.99.906-1.fc9.i386
awesome-3.0-0.8.rc6.fc9.i386 from bug 452427

How reproducible:

In half of cases the mod4 does not work, sometimes reset of Xserver does the job and mod4 key runs OK, but sometimes it does not did the trick.

Steps to Reproduce:
1. install awesome
2. log into in via GDM
3. mod4 key sometimes fails and sometimes it doesn't
  

Additional info:

It happens on RHEL with awesome-2 too, I ran, in the past, awesome on gentoo with no problem.
Comment 1 Michal Nowak 2008-09-09 03:14:24 EDT
Created attachment 316148 [details]
Mod4 key does not work, #1
Comment 2 Michal Nowak 2008-09-09 03:14:50 EDT
Created attachment 316149 [details]
Mod4 key does not work, #2
Comment 3 Michal Nowak 2008-09-09 03:15:26 EDT
Created attachment 316150 [details]
Mod4 key works
Comment 4 Peter Hutterer 2008-09-09 03:57:30 EDT
Please cross-check with Bug 239409. I have not yet succeeded in tracking it down though.
Comment 5 Michal Nowak 2008-09-09 04:36:12 EDT
It's dupe, thanks Peter, next time I'll do more querying next time.

*** This bug has been marked as a duplicate of bug 239409 ***

Note You need to log in before you can comment on or make changes to this bug.