Bug 461581 - perl-Catalyst-Runtime-scripts should depend on perl-parent
perl-Catalyst-Runtime-scripts should depend on perl-parent
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Catalyst-Devel (Show other bugs)
9
All Linux
medium Severity low
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 05:27 EDT by Allan Engelhardt
Modified: 2008-09-24 20:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 20:20:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Engelhardt 2008-09-09 05:27:03 EDT
Description of problem:
The perl-Catalyst-Runtime-scripts RPM package (and presumably perl-Catalyst-Devel ?) should depend on perl-parent

Version-Release number of selected component (if applicable): 5.7014-3.fc9.


How reproducible: Always.


Steps to Reproduce:
1. yum install perl-Catalyst-Runtime-scripts.noarch
2. catalyst.pl MyApp
3. cd MyApp
4. perl script/myapp_server.pl
  
Actual results:
Can't locate parent.pm in @INC (@INC contains: [...snip...]) at /home/allane/playpen/MyApp/script/../lib/MyApp.pm line 16.
BEGIN failed--compilation aborted at /home/allane/playpen/MyApp/script/../lib/MyApp.pm line 16.
Compilation failed in require at script/myapp_server.pl line 55.

Expected results:

[debug] Debug messages enabled
[debug] Statistics enabled
[debug] Loaded plugins:
[...snip...]

Additional info:

Do 

yum install perl-parent

to fix, but it would be nicer if the RPM package had the right dependency.
Comment 1 Chris Weyl 2008-09-11 00:33:18 EDT
(In reply to comment #0)
> Do 
> 
> yum install perl-parent
> 
> to fix, but it would be nicer if the RPM package had the right dependency.

Agreed.  Looks like this is actually in the code Catalyst::Helper generates (via catalyst.pl's invocation), and the Catalyst-Devel dist marks it as a requires, so I'll manually add it to that rpm.
Comment 2 Fedora Update System 2008-09-11 00:51:14 EDT
perl-Catalyst-Devel-1.08-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/perl-Catalyst-Devel-1.08-2.fc9
Comment 3 Fedora Update System 2008-09-12 01:14:46 EDT
perl-Catalyst-Devel-1.08-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Catalyst-Devel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8007
Comment 4 Fedora Update System 2008-09-24 20:19:57 EDT
perl-Catalyst-Devel-1.08-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.