Bug 461614 - Align kdump initscript with new xen /proc layout
Align kdump initscript with new xen /proc layout
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
All Linux
medium Severity high
: beta
: ---
Assigned To: Neil Horman
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 10:00 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 14:04:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kexec-tools patch (508 bytes, patch)
2008-09-09 10:00 EDT, Jay Turner
no flags Details | Diff

  None (edit)
Description Jay Turner 2008-09-09 10:00:44 EDT
Created attachment 316187 [details]
kexec-tools patch

Description of problem:
With the latest kernels, the /proc layout for xen has actually changed in that the /proc/xen directory exists even when not running the xen kernel.  kexec-tools has a check in the code to sort out if the i686 PAE kernel needs to be used and that check uses the existence of /proc/xen.  This conditional needs to be updated to check for /proc/xen/capabilities which only exists in the case the xen kernel is running.

Version-Release number of selected component (if applicable):
1.102pre-35.el5
Comment 1 Jay Turner 2008-09-09 10:02:49 EDT
As a result of this defect, kdump will not start on a system running the standard i686 kernel where the corresponding PAE kernel isn't also installed.  Even in the case the PAE kernel is installed, I suspect the resulting kdump image might not work well as it would be compiled with the PAE kernel when the standard kernel was actually executing at the time.
Comment 2 Neil Horman 2008-09-10 14:04:05 EDT
As per email discussion, this is actually a xen bug, since we now have a /proc/xen directory even on non xen kernels.  The decision has been made to remove that directory, and when it is gone, this will start working again.  So I'll close this as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.