Bug 461625 - Use type-safe enums in qpid::client::Session methods
Use type-safe enums in qpid::client::Session methods
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
low Severity medium
: 1.3
: ---
Assigned To: Alan Conway
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 11:29 EDT by Alan Conway
Modified: 2011-08-12 12:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 14:50:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2008-09-09 11:29:30 EDT
Description of problem:

AMQP enum types now have corresponding C++ enum definitions in framing/enum.h,
however the Session method signatures still use integral types. They should use the enum types to prevent user error & support calls caused by using the wrong enum type or using an incorrect integer value for an enum argument.
Comment 2 Alan Conway 2009-10-27 14:50:57 EDT
With the new API this is no longer important.

Note You need to log in before you can comment on or make changes to this bug.