Bug 461641 - plymouth isn't always getting updated after yum updates
plymouth isn't always getting updated after yum updates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 13:02 EDT by Ray Strode [halfline]
Modified: 2008-09-30 16:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 16:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2008-09-09 13:02:33 EDT
--- Additional comment from jlayton@redhat.com on 2008-09-09 12:18:21 EDT ---

Looks like the previous version of plymouth was:

Aug 29 07:12:15 Updated: plymouth-0.6.0-0.2008.08.27.2.fc10.x86_64

But I'm not sure that that explains what I saw. Here's a snippet from my yum log this morning. plymouth is updated to the new version:

Sep 09 07:24:35 Updated: libXft-devel-2.1.13-1.fc10.x86_64
Sep 09 07:24:37 Updated: plymouth-libs-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 07:24:38 Updated: plymouth-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 07:24:39 Updated: plymouth-plugin-spinfinity-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 07:24:39 Updated: plymouth-plugin-label-0.6.0-0.2008.09.05.3.fc10.x86_64

...new kernel is installed and rpm is updated. At this point -314 would hang at boot time. 

Sep 09 07:26:00 Installed: kernel-2.6.27-0.314.rc5.git9.fc10.x86_64
Sep 09 07:26:00 Updated: rpm-4.5.90-0.git8461.5.x86_64

...after I read Yanko's comments, I tried removing plymouth (thinking it might be an optional component):

Sep 09 09:59:24 Erased: mkinitrd
Sep 09 09:59:24 Erased: plymouth-plugin-spinfinity
Sep 09 09:59:26 Erased: plymouth
Sep 09 09:59:26 Erased: plymouth-plugin-label
Sep 09 09:59:27 Erased: plymouth-libs

...plymouth is removed. But looks like mkinitrd depends on it, so I reinstalled it:

Sep 09 10:00:16 Installed: mkinitrd-6.0.62-1.fc10.x86_64
Sep 09 10:00:16 Installed: plymouth-libs-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 10:00:17 Installed: plymouth-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 10:00:18 Installed: plymouth-plugin-spinfinity-0.6.0-0.2008.09.05.3.fc10.x86_64
Sep 09 10:00:19 Installed: plymouth-plugin-label-0.6.0-0.2008.09.05.3.fc10.x86_64

After this, I tried rebuilding the initrd and was able to successfully boot.

It seems like a yum update of the plymouth package wasn't sufficient to fix whatever the problem was, but uninstalling the package(s) completely and then reinstalling was.
Comment 1 Ray Strode [halfline] 2008-09-09 13:05:34 EDT
out of curiosity do you have a /bin/plymouthd or /bin/plymouth file (you shouldn't)?
Comment 2 Jeff Layton 2008-09-09 13:56:11 EDT
No, neither file exists on this machine.
Comment 3 Steve Dickson 2008-09-09 16:31:39 EDT
I have both...

rawhat$ ls /bin/plymouthd

/bin/plymouthd*

rawhat$ ls /bin/plymouth

/bin/plymouth*

rawhat$
Comment 4 Ray Strode [halfline] 2008-09-09 17:22:25 EDT
steved can you remove them and then run

/sbin/mkinitrd -f /boot/$(uname -r).img $(uname -r)

?
Comment 5 Steve Dickson 2008-09-10 09:07:54 EDT
The following steps did indeed allow my machine to boot
with a serial console:

mv /bin/plymouthd /bin/plymouthd.orig
mv /bin/plymouth /bin/plymouth.orig
mv /boot/initrd-2.6.27-0.314.rc5.git9.fc10.x86_64.img 
           /boot/initrd2.6.27-0.314.rc5.git9.fc10.x86_64.img.orig

/sbin/mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r)

thanks Ray!
Comment 6 Ray Strode [halfline] 2008-09-30 16:31:37 EDT
So jeremy fixed this today, I think:

- Remove mkinitrd requires to break the dep loop and ensure things
  get installed in the right order

Note You need to log in before you can comment on or make changes to this bug.