Bug 461674 - .treeinfo uses PAE kernel for [images-xen]
.treeinfo uses PAE kernel for [images-xen]
Status: CLOSED DUPLICATE of bug 458164
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 15:55 EDT by James Laska
Modified: 2013-09-02 02:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 16:49:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-09-09 15:55:46 EDT
The rawhide .treeinfo file points to the PAE kernel as the xen kernel.  Is this correct?  There are also missing xen images in the tree (which causes virt-install -p to fail).  

If this is intentional, we can move this bug over to track having virt-install use the PAE kernel.

If this is not intentional, we can just use this bug to track the missing xen images and the .treeinfo [images-xen] content?

$ curl http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/.treeinfo
[checksums]
images/pxeboot/vmlinuz-pae = sha1:528378c6e6641e8bf3887ae7148c0f3d527904ec
images/pxeboot/initrd-pae.img = sha1:a84478bf1567f8644c551217416cc3f7882b8334
images/pxeboot/efiboot.img = sha1:f694b6351e020c717828d68584f615ccbb3a7eab
images/pxeboot/initrd.img = sha1:38e01161f8f442af3837581e995ab73a70fe51fc
images/pxeboot/readme = sha1:9f09c62e398b755f46d28919b282864a0ba7a163
images/boot.iso = sha1:c3de36696ada920fe1bf262cb3039f762e02e0f0
images/pxeboot/vmlinuz = sha1:67c97dc84f6e3d7d62c68a58096ae1ad26ea029e
images/install.img = sha1:5a68e5ac240f259d86a9e5ec1161cd9001cee75c
images/readme = sha1:c815f147f2088d86996b6522fb53badeccb0d145
images/efidisk.img = sha1:459ade07d058589eb8f097f148c69a626dd18b7c
repodata/repomd.xml = sha1:a21ad1bb64090778211353cdde32ad8dac1843e5

[images-i386]
initrd = images/pxeboot/initrd.img
boot.iso = images/boot.iso
kernel = images/pxeboot/vmlinuz

[stage2]
mainimage = images/install.img

[images-xen]
initrd = images/pxeboot/initrd-PAE.img
kernel = images/pxeboot/vmlinuz-PAE

[general]
family = Fedora
timestamp = 1220954686.57
variant = 
totaldiscs = 1
version = development
discnum = 1
packagedir = 
arch = i386
Comment 1 Jeremy Katz 2008-09-09 16:03:37 EDT
This is correct.  With pvops, you have to be using the PAE kernel for xen on x86.

virt-install was supposed to be using the bits out of .treeinfo I thought.
Comment 2 James Laska 2008-09-09 16:09:32 EDT
The xen host is an F8 box (using python-virtinst-0.300.2-4.fc8) so it's likely this is fixed in newer python-virtinst.  I'll get around to testing that w/ xenner shortly ...
Comment 3 Cole Robinson 2008-09-09 16:12:18 EDT
virt-install does use treeinfo, on F9. However the F8 version (aka the last xen
dom0 version) doesn't have the .treeinfo code in virt-install. There is already
a bug for tracking this (bug 458164).
Comment 4 James Laska 2008-09-09 16:27:11 EDT
Thanks Cole, sounds like DUPing this against 458164 would make the most sense?
Comment 5 Cole Robinson 2008-09-09 16:49:57 EDT
Whoops, sorry, meant to do that :)

*** This bug has been marked as a duplicate of bug 458164 ***

Note You need to log in before you can comment on or make changes to this bug.