This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 461693 - Cobbler update failed
Cobbler update failed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael DeHaan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 18:24 EDT by john5342
Modified: 2008-09-11 16:06 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-11 10:27:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description john5342 2008-09-09 18:24:42 EDT
Description of problem:
Update of cobbler failed

Version-Release number of selected component (if applicable):
cobbler-1.2.0-1.fc9.noarch.rpm

How reproducible:


Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
Failed during update and gave a traceback:

Traceback (most recent call last):                                                                                                                                                  
  File "/usr/bin/cobbler", line 17, in <module>                                                                                                                                     
    import cobbler.cobbler as app                                                                                                                                                   
  File "/usr/lib/python2.5/site-packages/cobbler/cobbler.py", line 26, in <module>                                                                                                  
    import api                                                                                                                                                                      
  File "/usr/lib/python2.5/site-packages/cobbler/api.py", line 207                                                                                                                  
    <<<<<<< HEAD:cobbler/api.py                                                                                                                                                     
     ^                                                                                                                                                                              
SyntaxError: invalid syntax                                                                                                                                                         
Stopping cobbler daemon: [  OK  ]                                                                                                                                                   
Starting cobbler daemon: Traceback (most recent call last):                                                                                                                         
  File "/usr/bin/cobblerd", line 19, in <module>                                                                                                                                    
    import cobbler.api as bootapi                                                                                                                                                   
  File "/usr/lib/python2.5/site-packages/cobbler/api.py", line 207                                                                                                                  
    <<<<<<< HEAD:cobbler/api.py                                                                                                                                                     
     ^                                                                                                                                                                              
SyntaxError: invalid syntax                                                                                                                                                         
[FAILED]                                                                                                                                                                            
error: %post(cobbler-1.2.0-1.fc9.noarch) scriptlet failed, exit status 1


Expected results:
cobbler updates without issue

Additional info:
Comment 1 Michael DeHaan 2008-09-11 10:27:28 EDT
Hi John,

For whatever reason, Fedora has 1.2.0 in updates since updates have just been turned back on, though fixes have been in queue for some time and I submitted 1.2.1 a couple of days after 1.2.0 came out.   While Fedora mirrors will have 1.2.4 soon, you can also find the latest at 

http://people.fedoraproject.org/~mdehaan/files/cobbler/

Upgrading to 1.2.4 is recommended, and you can do this with RPM if you do not want to wait for the mirrors.

--Michael
Comment 2 john5342 2008-09-11 13:13:08 EDT
Fetched 1.2.4 straight from koji. Install was successful.

Would however note that the install was noisy which it shouldn't be. Output was:

Running Transaction
  Updating       : cobbler                                           [1/3]
reading from old config format: /var/lib/cobbler/distros
auto-removing old config format: /var/lib/cobbler/distros
reading from old config format: /var/lib/cobbler/repos
auto-removing old config format: /var/lib/cobbler/repos
reading from old config format: /var/lib/cobbler/profiles
auto-removing old config format: /var/lib/cobbler/profiles
reading from old config format: /var/lib/cobbler/systems
auto-removing old config format: /var/lib/cobbler/systems
  Cleanup        : cobbler                                           [2/3]
  Cleanup        : cobbler                                           [3/3]
Comment 3 Michael DeHaan 2008-09-11 15:44:57 EDT
Cobbler should not migrate your configs unless you replaced your modules.conf with modules.conf.rpmnew.
Comment 4 john5342 2008-09-11 15:57:27 EDT
I have never touched modules.conf and there is also no modules.con.rpmnew. In fact i have never even touched cobbler. Only installed a few months to solve a possible problem with another system but never ended up needing it so never touched any configs. It just sits there and gets updated with the rest of y packages.

Noise is not big deal for me. Just thought you should know it was appearing despite the fact the general rule in packaging is to keep the noise down to only showing errors.

New package does at least solve the issue with failing update.
Comment 5 Michael DeHaan 2008-09-11 16:06:42 EDT
That message for upgrading users is pretty signfigant and they would want to see it, for new installs, that should /not/ be there.

I am guessing it is a side effect of the past install not completing all the way though I can't be certain.  I would not be worried about it though I'll do some clean install testing to make sure in normal scenarios that output is not printed as it clearly doesn't apply.

Glad your update issue is resolved.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.