Bug 461715 - Anaconda GUI crashes in "Reinstall or upgrade" dialog
Anaconda GUI crashes in "Reinstall or upgrade" dialog
Status: CLOSED DUPLICATE of bug 374891
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 01:43 EDT by Martin Langhoff
Modified: 2008-09-10 09:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-10 09:26:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt (74.69 KB, text/plain)
2008-09-10 01:44 EDT, Martin Langhoff
no flags Details
anaconda.log (35.67 KB, application/octet-stream)
2008-09-10 01:45 EDT, Martin Langhoff
no flags Details

  None (edit)
Description Martin Langhoff 2008-09-10 01:43:45 EDT
Description of problem:

when running anaconda to upgrade an existing system, using the radio buttons on the "Install or upgrade" GUI dialog crashes. This happens both with keyboard navigation and with mouse-driven manipulation.

Version-Release number of selected component (if applicable):

$ rpm -qa anaconda*
anaconda-11.4.0.82-1.i386
anaconda-runtime-11.4.0.82-1.i386


How reproducible:

100% - this can be seen with the official F9-DVD installer.

Steps to Reproduce:
1. Install Fedora 7
2. Start an upgrade with the F9-DVD
3. On the "Install or upgrade" dialogue...
4a. Use tabs to change focus to radio selectors, and arrow down to pick 'upgrade'
4b. Click on the 'upgrade' radio button
  
Actual results:

...Debug window pops up...

Expected results:

...an upgrade! :-)

Additional info:

Logs attached...
Comment 1 Martin Langhoff 2008-09-10 01:44:28 EDT
Created attachment 316272 [details]
anacdump.txt
Comment 2 Martin Langhoff 2008-09-10 01:45:00 EDT
Created attachment 316273 [details]
anaconda.log
Comment 3 Chris Lumens 2008-09-10 09:26:16 EDT
Gah, this bug.  Should be fixed in F10.

*** This bug has been marked as a duplicate of bug 374891 ***

Note You need to log in before you can comment on or make changes to this bug.