Bug 461720 - make wine1.1.4 source code erro
make wine1.1.4 source code erro
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 03:01 EDT by LaiSiMin
Modified: 2009-03-24 11:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-24 11:20:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Wine/dlls/user32/tests/menu.c (97.76 KB, text/x-csrc)
2008-11-21 16:30 EST, Peter Kovář
no flags Details
Temporary assembler language file generated from menu.c (152.00 KB, application/octet-stream)
2008-11-21 16:34 EST, Peter Kovář
no flags Details

  None (edit)
Description LaiSiMin 2008-09-10 03:01:08 EDT
Description of problem:
gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings -Wtype-limits -Wpointer-arith  -g -O2  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7415: Warning: end of file not at end of a line; newline inserted
{standard input}:7650: Error: unbalanced parenthesis in operand 1.
gcc: 内部错误:段错误 (程序 cc1)
请提交一份完整的错误报告。
具体步骤请参见 <http://bugzilla.redhat.com/bugzilla>。
make[2]: *** [menu.o] 错误 1
make[2]: Leaving directory `/media/disk-1/wine-1.1.4/dlls/user32/tests'
make[1]: *** [user32/tests] 错误 2
make[1]: Leaving directory `/media/disk-1/wine-1.1.4/dlls'
make: *** [dlls] 错误 2


Version-Release number of selected component (if applicable):
wine1.1.4



How reproducible:
download the wine1.1.4 sourcecode and decompression it ,after ./configure make depend &&make,the erro will happen.
 

Steps to Reproduce:
1.download the wine1.1.4 sourcecode and decompression it
2../configure 
3.make depend && make
  
Actual results:
make wine1.1.4 sourcecode unsuccessfull.

Expected results:
make wine1.1.4 successfull and then make install wine1.1.4

Additional info:
Comment 1 Andreas Bierfert 2008-09-10 16:27:43 EDT
What are you trying to do here? 1.1.4 builds fine on F9 and has been submitted as an upgrade already.

https://admin.fedoraproject.org/updates/wine-1.1.4-1.fc9
Comment 2 LaiSiMin 2008-09-10 21:45:09 EDT
   I'm sorry, this is my first time to submitte bug. 
   I just want to configure the newest wine1.1.4 soucecode, when find this erro I was so exciting.
   My English is not well, so I didn't see wie1.1.4 has benn submitted, to my appologize again.
Comment 3 nish 2008-09-16 13:20:29 EDT
wine1.1.4 on fedora9 

gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings -Wtype-limits -Wpointer-arith  -g -O2  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7415: Warning: end of file not at end of a line; newline inserted
{standard input}:7650: Error: unbalanced parenthesis in operand 1.
gcc: 内部エラー: セグメンテーション違反です (プログラム cc1)
完全なバグレポートを送ってください。
Comment 4 Michal Pomorski 2008-11-09 21:25:40 EST
I would like to confirm this is a real bug somewhere between gcc and wine.
Trying to compile newest git tree of wine as of Nov 10 2008 ( Release 1.1.8. ) on fc9 with gcc 4.3 gives the following:
(...)
make[2]: Entering directory `/home/shimo/code/wine/dlls/user32/tests'
gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings -Wtype-limits -Wpointer-arith  -g -O2  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7374: Warning: end of file not at end of a line; newline inserted
{standard input}:8481: Error: unbalanced parenthesis in operand 2.
gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
make[2]: *** [menu.o] Error 1
make[2]: Leaving directory `/home/shimo/code/wine/dlls/user32/tests'
make[1]: *** [user32/tests] Error 2
make[1]: Leaving directory `/home/shimo/code/wine/dlls'
make: *** [dlls] Error 2

gcc --version
gcc (GCC) 4.3.0 20080428 (Red Hat 4.3.0-8)


Also as a reference I found similar report: 
http://www.mail-archive.com/bug-binutils@gnu.org/msg00025.html

"
On Tue, Feb 15, 2005 at 05:06:01PM +0000, Hamilton, Ian wrote:
>       cmpl $(100/4), %eax
> 
> [EMAIL PROTECTED] temp]$ i386-elf-as -a test.S
> test.S: Assembler messages:
> test.S:2: Error: unbalanced parenthesis in operand 1.

For compatibility with other assemblers, '/' starts a comment on the
i386-elf target.  So you can't use division.  If you configure for
i386-linux (or any of the bsds, or netware), you won't have this
problem.

-- 
Alan Modra
IBM OzLabs - Linux Technology Centre
"

This looks like gcc generating bad assembly which shouldn't happen whatever the compiled application.
Comment 5 Peter Kovář 2008-11-21 16:30:43 EST
Created attachment 324348 [details]
Wine/dlls/user32/tests/menu.c

Here is the C file from Wine, which is causing compilation failure.
Comment 6 Peter Kovář 2008-11-21 16:34:15 EST
Created attachment 324350 [details]
Temporary assembler language file generated from menu.c

gcc -m32 -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings -Wtype-limits -Wpointer-arith  -g -O2  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7375: Warning: end of file not at end of a line; newline inserted
{standard input}:8481: Error: unbalanced parenthesis in operand 2.
gcc: Internal error: Segmentation fault (program cc1)

gcc -save-temps was used to save this file

cpp-4.3.0-8.x86_64
gcc-4.3.0-8.x86_64
binutils-2.18.50.0.6-6.fc9.x86_64
Comment 7 Fedora Update System 2009-02-24 15:40:45 EST
wine-1.1.14-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Jon Dufresne 2009-03-24 11:20:34 EDT
Thank you for your bug report.

As far as I can tell, the original bug report is that a third party software package (wine; and not the wine shipped with fedora) does not compile. Unless you can demonstrate that this occurs due to a bug in the Fedora's packaged gcc rather than a bug in wine's source code, you'll need to report this bug to wine. http://bugs.winehq.org/

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.