Bug 461724 - dhcpv6 can only be built by root
dhcpv6 can only be built by root
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dhcpv6 (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-10 03:58 EDT by loic
Modified: 2008-09-29 01:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 18:00:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
typescript.txt (44.43 KB, text/plain)
2008-09-26 17:59 EDT, David Cantrell
no flags Details

  None (edit)
Description loic 2008-09-10 03:58:45 EDT
Description of problem:
dhcpv6 can only be built by root, because the file named configure is already shipped in dhcp-0.10.tgz and is read-only.

Version-Release number of selected component (if applicable):
0.10-24_EL4

How reproducible:
Always

Steps to Reproduce:
1. Build dhcpv6 while not being root
2.
3.
  
Actual results:
rpmbuild fails during %build phase with :
autom4te: cannot open configure: Permission denied

Expected results:
rpmbuild should end normally

Additional info:
Comment 1 loic 2008-09-10 04:12:28 EDT
Oops, I didn't saw bug 185598 and the %_fixperms workaround. Sorry.
I'm not sure that setting %_fixperms is a good idea, since this assumes that all
packages have correct %defattr and %attr settings, which is not obvious. It would be better to correct dhcpv6.spec as the user in 185598 suggested.
Comment 2 David Cantrell 2008-09-26 17:59:14 EDT
I am able to build the dhcpv6 package as a non-root user on RHEL 4.7 just fine.

You have to create a local rpmbuild directory and set that as your rpmbuild topdir, but this is standard practice.

The attached typescript.txt shows what I did.
Comment 3 David Cantrell 2008-09-26 17:59:50 EDT
Created attachment 317840 [details]
typescript.txt
Comment 4 loic 2008-09-29 01:58:47 EDT
Of course the build environment was fine. As I said, setting %_fixperms solved the problem of the non-writable configure file. Thanks for your answer.

Note You need to log in before you can comment on or make changes to this bug.